On Thu, 2014-07-10 at 04:14 +0000, Junio C Hamano wrote:
> On Wed, Jul 9, 2014 at 4:49 PM, Keller, Jacob E
> <jacob.e.kel...@intel.com> wrote:
> > On Wed, 2014-07-09 at 15:59 -0700, Junio C Hamano wrote:
> >>
> >> What kind of things are missing, exactly?  Perhaps that is something
> >> you need to fix, instead of mucking with the top-level Makefile.
> >
> > It uses the git from my environment instead of the git I have built,
> > which is bad since I don't really want to run make install.
> Are you sure about that?  Try adding something like
>   die("I am broken");
> at the very beginning of main() in git.c, rebuild your git (i.e.
> "make", not "make install")
> and then
>   $ cd t
>   $ sh ./t1234-test.sh -v
> for any of the test scripts. You should see any test piece that runs "git" 
> sees
> "git" dying with that message.
> Otherwise, there is something wrong with git you are building. Unless you have
> a patch or two to t/test-lib.sh or something that breaks the test framework, 
> you
> should be able to test what you just have built without getting affected by 
> what
> is installed in your $PATH. After all, that is how we bootstrap git
> from a tarball
> without any installed version, and friends do not force friends install 
> without
> testing first ;-)

This is even more interesting. I tried your die check, and it definitely
runs the correct version of git.

However, if I run the test directly:

cd t ; sh t3200-branch.sh -v

it passes.

if I run:

make test

that particular test fails. If I have this patch applied, and I run

make t/t3200-branch.sh

it also fails.

I have done this directly on current master branch. So something is
differing between the two test runs.

Also, if I run:

make -C t t3200-branch.sh

that passes, so it really *is* something setup by the main makefile.

Any more suggestions?


Reply via email to