On Sat, Jul 12, 2014 at 03:44:06PM +0100, Ramsay Jones wrote:

> > -   return alloc_node(&name##_state, sizeof(type));         \
> > +   return alloc_node(&name##_state, flag, sizeof(type));   \
> >  }
> I don't particularly like 'flag' here. (not a massive dislike, mind you:)
> Perhaps: flag->object_type, type->node_type?
> Or, if that's too verbose, maybe just: flag->type, type->node?

Me either, but as you noticed, type was taken. Your suggestions seem
fine. We could also just do away with the macro as discussed earlier (we
already do in the commit_node case, anyway...).

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to