On Tue, 2014-07-15 at 15:47 -0700, Junio C Hamano wrote:
> Jacob Keller <jacob.e.kel...@intel.com> writes:
> > extern void set_error_routine(void (*routine)(const char *err, va_list
> > params));
> > +extern void pop_error_routine(void);
> pop that undoes set smells somewhat weird. Perhaps we should rename
> set to push? That would allow us catch possible topics that add new
> calls to set_error_routine() as well by forcing the system not to
> link when they are merged without necessary fixes.
Also curious what your thoughts on making every set_*_routine to be a
stack? For now I was only planning on error but it maybe makes sense to
change them all?