Running on Windows with latest version of Git. 1.9.4. Also had this trouble 
with 1.8.2 but upgraded hoping it would fix the problem.

When I do a reset on several files, it says they were successfully reverted 
they still show up as modified when I do a git status. In this case it's just a 
newline character at the end of the file. I also tried a reset -- hard and they 
files still show up! What the heck! Help please.
In trying to reproduce this, I re-cloned the git repo from the server, which 
was in the exact clean state before I started last time. No files have been 
modified after cloning, all are identical. Then, I created a new branch 
(totally new, not tracking a remote branch). Viola - I now have these files 
show up in my git status as modified. Please note that these are files that 
have been tracked for several previous commits.
Just to clarify - the only command I ran to make this happen is: git checkout 
-b newbranch

And GitGui shows the files as identical even when compare whitespace is turned 

To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to
More majordomo info at

Reply via email to