I ran git on my newly-set-up OS X Mavericks machine, and get:

        $ git
         Agreeing to the Xcode/iOS license requires admin privileges,
please re-run as root via sudo.

Running 'git --verision' gives the same result.  This seems
problematic in a few ways, and I am wondering if the git community is
interested in addressing it:

1. Why do I have to agree to Apple's licensing terms to use an LGPL
program?  Is this appropriate?  Is it allowed under the LGPL?

2. This is a significant problem for me, because I'm using a work
machine and do not have admin access.

3. The version of git I ran is clearly NOT a plain vanilla "official"
git, it is a derivative work.  Has Apple provided the source code of
the special version that I just ran?  If not, that would seem to be a
violation of the LGPL.


To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to