On Tue, Aug 12, 2014 at 5:56 AM, Luke Campagnola
<luke.campagn...@gmail.com> wrote:
> Greetings,
> I have been working happily with git for a couple of years, and ran
> into a mysterious issue today: after running a git-pull during which I
> saw the message "Auto packing the repository for optimum performance".
> I now receive the error "Fatal: not a git repository" when running any
> git commands, and a little investigation revealed that my .git/refs
> directory has gone missing, presumably because the refs were all
> combined into .git/packed-refs. To restore access to the repository,
> all I needed was to `mkdir .git/refs`. Is this a known bug?

Not to me.

> It seems
> like either git should tolerate the absence of a .git/refs directory,
> or the auto packer should not remove it.

I tried to clone from vispy.git, running 'git gc' manually and
'pack-refs' (which should be in charge of removing empty dirs with
v1.9.1. Things worked fine. Looked at
refs.c:try_remove_empty_parents() as well. Still could not find any
bug there.. So no good news. I don't suppose that if you run "git gc"
again, it would remove $GIT_DIR/refs one more time?
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to