On Wed, Nov 19, 2014 at 01:40:23PM -0800, Stefan Beller wrote:

>  {
> -     struct ref_update *update;
> -
> -     assert(err);
> -
> -     if (transaction->state != REF_TRANSACTION_OPEN)
> -             die("BUG: create called for transaction that is not open");
> -
> -     if (!new_sha1 || is_null_sha1(new_sha1))
> -             die("BUG: create ref with null new_sha1");
> -
> -     if (check_refname_format(refname, REFNAME_ALLOW_ONELEVEL)) {
> -             strbuf_addf(err, "refusing to create ref with bad name %s",
> -                         refname);
> -             return -1;
> -     }

You claimed in the cover letter that only BUG messages were changed. But
I think this third one is a real user-visible message.

That being said, I think the sum total of the change to the message is
s/create/update/, and it's probably fine.

-Peff
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to