Only warn when an extension starts with a dot, because it's unlikely to
be what the author wanted, but leave the dot there.  This both forces
the author to fix the extension, and allows future use of the dot if
wanted.

Also, include the proxy plugin name in the warning message.

Follow-up to #1212.
You can view, comment on, or merge this pull request online at:

  https://github.com/geany/geany/pull/1233

-- Commit Summary --

  * Do not strip dots from proxy plugin extensions

-- File Changes --

    M src/plugins.c (20)

-- Patch Links --

https://github.com/geany/geany/pull/1233.patch
https://github.com/geany/geany/pull/1233.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/geany/geany/pull/1233

Reply via email to