> I didn't check how hard it'd be to support both GTK2 and GTK3, but it seems a 
> little sad to switch from one restriction to the other. Well, I guess it 
> becomes less and less mandatory to support GTK2, but still.

@b4n, @pmjobin suggest the same thing I have said elsewhere, don't support both 
in one plugin just make this GTK3 version a separate plugin, named 
"debugger-gtk3" for eg, the build protections should prevent both being built, 
and loading protections won't let the wrong one be loaded into Geany if somehow 
both get built.

Then all that has to happen later is the GTK2 version just disappears.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/geany/geany-plugins/pull/645#issuecomment-365789388

Reply via email to