On Tue, Oct 11, 2016 at 07:53:09PM +0000, Menaka Mohan wrote:
> Hi,
>
>
> I am Menaka M. I am interested in participating in this round of Outreachy 
> under Gluster. I am new to this open source world. Kindly help me with the 
> following query.
>
>
> I have set up the Gluster development environment with two servers and one 
> client. I am trying to run the basic bench test on the Gluster cluster from 
> this GitHub 
> repo<https://github.com/gluster/gbench/tree/master/bench-tests/bt-0000-0001>. 
> I also have IOZone installed. While trying to run the provided script, i get 
> the following error. I was trying to identify the cause of the error. Kindly 
> help me with that.
>
> So, I learned more about IOZone and also the performance testing section in 
> the Gluster docs. With that knowledge and to learn more, I have gone through 
> the code and running iozone commands mentioned in the GlusterBench.py script 
> individually.
>
> If I am asking a very basic thing, apologies. I will quickly learn things.
>
> Regards,
> Menaka M
>

Hi Menaka,

Thanks for taking a look at gbench. It appears that you have uncovered a bug in
our documentation and code.

Shyam is the expert here and I'll let him chime in. You need an environment
variable with CLIENTS and SERVER to get this working. So when you run this, you
need at least two machines (VMs would be best. Happy to guide you on how to set
this up if you'd like). It would look something like this:

CLIENTS="192.168.0.1 192.158.0.2" SERVERS="192.168.0.3 192.168.0.3" python 
GlusterBench.py -s 64 -f 10000 -n 5 -v

I'm making a lot of assumptions here. If there's anything that is confusing,
let me know and I'm happy to clarify. I'll let Shyam jump in later today (he's
in EST) to chime with anything else I've missed.

--
nigelb
_______________________________________________
Gluster-devel mailing list
Gluster-devel@gluster.org
http://www.gluster.org/mailman/listinfo/gluster-devel

Reply via email to