On Fri, Oct 13, 2006 at 01:16:42PM +0200, Udo Giacomozzi wrote:
> Hello strk,
> 
> Friday, October 13, 2006, 12:46:51 PM, you wrote:
> s> Am I right that set_invalidated() should be called by
> s> sprite_instance::get_member() when members are _xscale, _yscale, _x, _y,
> s> _width or _height ? (there's no such call currently)
> 
> AFAIK get_member() does a read access, so this would not modify the
> sprite. set_member() invokes set_invalidated() indirectly because it
> sits in set_matrix(), set_cxform() and friends.

Yes, sorry, I meant set_member. We should add a comment right
on the side of set_matrix() so we know that we should leave the
set_matrix() call for its side-effects in case we'll feel like
using a more direct update of it (it happened to me)

--strk;


_______________________________________________
Gnash-commit mailing list
[email protected]
http://lists.gnu.org/mailman/listinfo/gnash-commit

Reply via email to