FWIW, this total system crash has been isolated to the kernel.  Kernel 5.17.5-76051705 crashes.  Which was pushed out to apt on, guess what, May 26, 2022, the date my computer went to hades.

Kernel 5.15.0-37-generic does not crash.  Kernel 5.18.2 also crashes, only if I use TyCommander, but not necessarily during a USB flashing.  I had 5.18.2 crash while I was using Firefox, but while Arduino IDE and TyCommander were active.

Now running on 5.15 and things are stable.

I know nothing about kernels and stuff like this.  Been forced into it.  An average Joe like me shouldn't have to deal with this kind of thing.

TyCommander works fine on an RPI4 running Raspberry Pi OS 64 bit, which as I understand it is a Debian derivative.  The kernel is 5.15.30, according to Wikipedia.  Not looking forward to an update of that kernel.

I have no idea how to make a minimal dying example for any developers...

On 6/6/22 4:05 PM, Bruce Labitt wrote:
Followup with SW related items.

$ cat /etc/os-release
ID_LIKE="ubuntu debian"

$ uname -a
Linux pop-os 5.17.5-76051705-generic #202204271406~1653440576~22.04~6277a18 SMP PREEMPT Wed May 25 01 x86_64 x86_64 x86_64 GNU/Linux

Tytools from https://github.com/Koromix/tytools
Teensyduino from: https://www.pjrc.com/teensy/td_download.html
Arduino download from: https://www.arduino.cc/en/software V1.8.19.
Data on Teensy 4.1 microcontroller (Arm M7, NXP IMXRT1060) https://www.pjrc.com/store/teensy41.html IMXRT1060 Processor Reference Manual https://www.pjrc.com/teensy/IMXRT1060RM_rev3.pdf

Me, I am writing code to make an electronic lead screw for my lathe. Motor control works with NEMA-24 stepper motor and rotary encoder.  Working on the UI on a touch panel tft display.  Or, I was, until my laptop crashed...

On 6/6/22 3:47 PM, Bruce Labitt wrote:

Will try my best.  It's tough to keep your cool when your life, ie. your own computer is crapping out.  Much easier, when it is someone else's.  Pity the machine is not up at the moment.  Been busy transferring my life to an RPI4, which hasn't been as easy as it seems like it should.  Writing this on my RPI4-8GB with RaspiOS-64bit.

Laptop in question, with the problem: System76 Oryx6. 32GB RAM, 1TB SSD Samsung 970 EVO Plus

HW Details:


Intel-10875H CPU, Intel HM470 chipset, MX25L12872F flash chip running System76 Open Firmware BIOS, ITE IT5570E runningSystem76 EC <https://github.com/system76/ec>, NVIDIA GeForce RTX 2060, 15.6" 1920x1080@144Hz LCD, LCD panel: Panda LM156LF1F (or equivalent) External video outputs: 1x HDMI, 1x Mini DisplayPort 1.4, 1x DisplayPort over USB-C
MemoryUp to 64GB (2x32GB) dual-channel DDR4 SO-DIMMs @ 3200 MHz -- 32 GB

Networking:Gigabit Ethernet,M.2 PCIe/CNVi WiFi/Bluetooth,Intel Wi-Fi 6 AX200/AX201

Power: 180W (19.5V, 9.23A) DC-in port,Barrel size: 5.5mm (outer), 2.5mm (inner),Included AC adapter: Chicony A17-180P4A,AC power cord type: IEC C5,73Wh 3-cell battery

Sound:Internal speakers & microphone,Combined headphone & microphone 3.5mm jack,Combined microphone & S/PDIF (optical) 3.5mm jack,HDMI, Mini DisplayPort, USB-C DisplayPort audio

Storage:1x M.2 (PCIe NVMe or SATA) - NVME 1 TB installed, 1x M.2 (PCIe NVMe only) - empty,MicroSD card reader

USB:3x USB 3.2 Gen 1 Type-A,1x USB Type-C with Thunderbolt 3

Dimensions:15": 35.75cm x 23.8cm x 1.98cm, 1.99kg

=== End HW details ==============================================================================================================

Pop-OS-64 bit.  22.04.  Fresh install over existing Ubuntu 20.04 LTS.

I need to reboot the computer to get the kernel stuff.  Will followup with uname -a.

Problem occurs when using USB to program Teensy 4.1 microcontroller.  Active programs at time of crash = Arduino IDE V 1.8.19, Teensyduino 1.56 (required to allow Arduino to recognize and program Teensy microcontrollers), and Tytools, 0.9.7, which is a tool to program and manage Teensy processors.  Prior to 26 May 2022, this all worked flawlessly.

And, the above SW does work flawlessly on the RPI4B, running RaspberryPiOS-64bit, but not on my laptop.  On my laptop I get system crashes.

Only clues I have found are in syslog, and dmesg, but they only show some normal USB transactions, then the computer powering up again.

Thanks Ben, for at least answering (humoring?) me.  Been an awful week with this crash.  These crashes are so bad, that there's practically nothing in the logs.  Last entry is using the USB port.  And the power turns off.  This is a stab at it.  Let me know if there's anything else I need to add.  Beats me what the crucial details are, if I knew them, it would have been fixed by now.

The title of the thread was really about how to go about doing the debugging.  The methodology.  It's improbable that anyone else would have experienced this particular crash type.

On 6/6/22 14:09, Ben Scott wrote:
On Sun, Jun 5, 2022 at 12:09 PM Bruce Labitt
<bruce.lab...@myfairpoint.net>  wrote:
I am experiencing severe Linux crashes ...
Long meandering messages with critical details hidden throughout and
others omitted entirely will reduce the likelihood that others will
give you help for free.  (Or even when paid.)

In particular, specify what hardware you have, and the software you're
running, in one place.  If it's a scavenger hunt just to find that
information you'll get a poor response.  I didn't see any mention of
the model of machine, for example.  List major components with model
or type (CPU model and speed, RAM size, type and size of storage,
model/type video controller, etc.).  You mention distribution and
version, which is good, but also please provide kernel version.  Also
include steps to reproduce (when it happens, when it doesn't),
commands you've tried, places you've looked for files, error messages
received, etc., etc.

I know you've been around long enough that you've seen plenty of bug
reports and knowledge base articles and the like.  Follow their


-- Ben
gnhlug-discuss mailing list

gnhlug-discuss mailing list

gnhlug-discuss mailing list

gnhlug-discuss mailing list

Reply via email to