On Sun, Feb 20, 2005 at 10:57:10PM +0000, Neil Williams wrote: Your patch makes the comment read:
> Returns the GList of kvp_frame's (not to be confused with GList's of > something > else!) from the given kvp_frame. This one is non-copying -- the caller can > modify the value directly. The returned GList is a list of KvpValues of any > type, including mixed. Cast each list gpointer to a KvpValue and use the > KvpValue->type to determine the type of value at each position in the list. > GList* kvp_value_get_glist ( const KvpValue * value ) The comments you added are corrent. IMO, the first sentence should just be deleted. The first sentence _was_ factually wrong, now it's just unparsable. The parts that are parsable contradict the third sentence. Changing plural "kvp_frames" to possessive "kvp_frame's" doesn't help -- it makes no sense. And "the given kvp_frame"? What kvp_frame? The only argument is a KvpValue, and if its sub-type _happens_ to be KvpFrame, then this function returns NULL. -chris _______________________________________________ gnucash-devel mailing list [email protected] https://lists.gnucash.org/mailman/listinfo/gnucash-devel
