On Tue, 2005-09-06 at 09:34 -0400, Derek Atkins wrote: > I see no reason not to use the code in core-utils in the backends. > That's what core-utils is there for.
Why isn't this code in lib/libc? That's where code should be that provides functionality that may be missing from the underlying system. As I see it, the following should occur: 1) The test from src/core-utils/core-utils.h requiring either setenv() or putenv() should be moved into configure. Developers should never get past configure if their platform doesn't provide one of these two functions. 2) The rest of the file src/core-utils/core-utils.h can be deleted. 3) The file src/core-utils/core-utils.c should be moved to lib/libc/setenv.c. It should provide the setenv and unsetenv functions on platforms where HAVE_SETENV is false. (The current functions can just be renamed.) 4) Gnucash should call setenv/unsetenv. David _______________________________________________ gnucash-devel mailing list [email protected] https://lists.gnucash.org/mailman/listinfo/gnucash-devel
