Actually, John, I was renaming the report in its options page and saving the result. I tried both the Save button and the Save As button without success (expecting in the latter case to get a second saved report under the new name, allowing me to delete the first).

In the olden days, the report title was the controlling aspect of a stored report, and I was changing that, expecting it to propagate through. Old habits die hard.



On 8/12/2019 11:41 PM, John Ralls wrote:

On Aug 12, 2019, at 9:23 AM, David T. via gnucash-devel 
<> wrote:

Sending this to -Dev because of the technical aspect of the problem...

Over the years, my Saved Reports list had gotten unruly, with various one-off 
reports littering the folder. In an effort to figure out which reports were 
still valid, I undertook to open every report and delete those that were no 
longer useful to me.

However, the process was long, so I needed some way to flag the reports that I *had* 
vetted, and I chose to add an asterisk ("*") to the end of the report title. 
This postfix tagging worked fine; the tagged reports showed up in the list of reports 
with their new names, and they all ran just fine.

Now, having completed the process, I no longer need to keep track of which 
reports have been checked, and I thought I might remove these tags. 
Unfortunately, renaming the report (either by removing the text, or by adding 
some other text in its place) doesn't work; the asterisk remains regardless.

I realize that I can go into the saved-reports-2.8 file and manually rename 
them all, but that seemingly defeats the purpose of a user interface...
This is from the "saved report configurations" dialog using the "rename" button 
that looks like an edit icon?

I can add and remove asterisks from a report name there with no issues. It 
doesn't seem to matter whether I quit GnuCash between edits.

John Ralls

gnucash-devel mailing list

Reply via email to