Hello,

Thank you very much for your review.

Anton Shepelev wrote:
> Here the function name's suffix is 132, but in your
> actual patch it is 123:
>
>>   pcsc_control = dlsym (handle, "SCardControl123");

My bad.  It's a typo of mine.  I think that it comes from
the version 1.3.2 of the PC/SC implementation.

Attached is the revised patch.
-- 
>From 50680d54eae927e577cc2c2f17c8c3f09b4d52d8 Mon Sep 17 00:00:00 2001
Message-ID: <50680d54eae927e577cc2c2f17c8c3f09b4d52d8.1790297399.git.gni...@fsij.org>
From: NIIBE Yutaka <[email protected]>
Date: Fri, 25 Sep 2026 09:48:53 +0900
Subject: [PATCH] scd: Fix pinpad handling for macOS.
To: [email protected]
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="------------2.47.3"

This is a multi-part message in MIME format.
--------------2.47.3
Content-Type: text/plain; charset=UTF-8; format=fixed
Content-Transfer-Encoding: 8bit


* scd/apdu.c [__APPLE__] (pcsc_init): Try SCardControl132 firstly.

--

Co-authored-by: Mario Hoberg
Signed-off-by: NIIBE Yutaka <[email protected]>
---
 scd/apdu.c | 6 ++++++
 1 file changed, 6 insertions(+)


--------------2.47.3
Content-Type: text/x-patch; name="0001-scd-Fix-pinpad-handling-for-macOS.patch"
Content-Transfer-Encoding: 8bit
Content-Disposition: attachment; filename="0001-scd-Fix-pinpad-handling-for-macOS.patch"

diff --git a/scd/apdu.c b/scd/apdu.c
index 6b874ef29..b54aeaf0e 100644
--- a/scd/apdu.c
+++ b/scd/apdu.c
@@ -1182,6 +1182,12 @@ pcsc_init (void)
       pcsc_end_transaction   = dlsym (handle, "SCardEndTransaction");
       pcsc_transmit          = dlsym (handle, "SCardTransmit");
       pcsc_set_timeout       = dlsym (handle, "SCardSetTimeout");
+#ifdef __APPLE__
+      /* Apple keeps old name, gives a different name for new API.  */
+      pcsc_control           = dlsym (handle, "SCardControl132");
+      /* If it's not available, try "SCardControl" */
+      if (!pcsc_control)
+#endif
       pcsc_control           = dlsym (handle, "SCardControl");
 
       if (!pcsc_establish_context

--------------2.47.3--


_______________________________________________
Gnupg-users mailing list
[email protected]
https://lists.gnupg.org/mailman/listinfo/gnupg-users

Reply via email to