On 4/3/07, Carlo Calica <[EMAIL PROTECTED]> wrote: > My 2 cents: use $(), easier nesting; keep source, more readable.
And here go mine: use $() when nesting, `` in simple cases like "for i in `one_command`". There may be old bits of code there using nested `` with ugly backquoted-backticks ( \` ), but I'm not doing this anymore, and using $() whenever I have to nest. -- Hisham > On 4/2/07, Jonas Karlsson <[EMAIL PROTECTED]> wrote: > > On Mon, 02 Apr 2007 20:25:31 +0200, Lucas C. Villa Real > > <[EMAIL PROTECTED]> wrote: > > > > > On 4/1/07, Jonas Karlsson <[EMAIL PROTECTED]> wrote: > > >> You know you could have just added an $ instead. I really think we > > >> should > > >> use parenthesis instead of backticks as the bash devs have marked > > >> backticks as deprecated and parenthesis are easier to nest (as well as > > >> more portable? - I've read some comment on that but can't give any > > >> source > > >> :/ ). > > > > > > I always prefered to use backticks instead. Sometimes I get confused > > > when I see $() and mentally read it as a variable. Having $() > > > colorized by the syntax highlighting also isn't that attractive.. I'm > > > not "against" using $(), I just don't like it that much. > > > > > Otoh I don't like backticks, just because I think it's harder to read. > > > > Just to add to my cause in this, one of the bugs with bash that was fixed > > with the patches I submitted to the recipe was a bug regarding the parsing > > of just backticks, even if it was a special case. > > > > >> At the same time I think we should use '. foo' instead of 'source foo', > > >> where the former is more portable (1). > > > > > > Ah, we're *requiring* Bash to interpret the scripts, so I don't think > > > portability is an issue. 'source' improves readability a lot. 'source' > > > support was even merged into Busybox' ash shell to conform to legacy > > > scripts. I strongly like to keep using 'source'. > > > > > Ok, if even busybox supports source, I think we can safely stick to that. > > :) > > > > >> Maybe have some document regarding recommended coding standards (if that > > >> doesn't exist and I've missed it). > > > > > > I think the only documentation we have in this sense is TemplateScript > > > in the Scripts package. Feeding the wiki might be a good thing. > > > > > > > -- > > /Jonas > > > > Using Opera's revolutionary e-mail client: http://www.opera.com/mail/ > > _______________________________________________ > > gobolinux-devel mailing list > > gobolinux-devel@lists.gobolinux.org > > http://lists.gobolinux.org/mailman/listinfo/gobolinux-devel > > > > > -- > Carlo J. Calica > _______________________________________________ > gobolinux-devel mailing list > gobolinux-devel@lists.gobolinux.org > http://lists.gobolinux.org/mailman/listinfo/gobolinux-devel > _______________________________________________ gobolinux-devel mailing list gobolinux-devel@lists.gobolinux.org http://lists.gobolinux.org/mailman/listinfo/gobolinux-devel