If you are exporting your interface but hiding your implementation, I usually 
name my interface Customer and my struct customerImpl. If you are using your 
interface for mocking purposes only, I would name it MockedCustomer. If you're 
exporting both the interface and its implementations, I would give a generic 
name to my interface (eg. Customer) and specific names to its implementations 
(eg. HighPriorityCustomer, SpecialNeedCustomer).

-- 
You received this message because you are subscribed to the Google Groups 
"golang-nuts" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to golang-nuts+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to