I do like the idea, but the form looks strange IMO. I'd rather make the
"Must" convention a new keyword for the first example, and another one for
the second (though I don't see a clear keyword for that).

For a panic on error you'd write :

data := must error_func()

Maybe the "try" keyword would be a good choice for the second example since
it's been clearly stated that try ... catch blocks won't be implemented in
go, which would give something like :

data, err := try panic_func()

But somehow it sounds quite redundant with the possibility to recover from
panics? Don't know

Le jeu. 22 nov. 2018 à 11:16, 'yinbingjun' via golang-nuts <
golang-nuts@googlegroups.com> a écrit :

> For an error function:
>
> data, err := error_func(…..)
>
> can be changed to panic style:
>
> data := panic error_func(……)
>
>
>
> And for a panic function:
>
> data := panic_func(……)
>
> can be changed to error style:
>
> data, err := error panic_func(…...)
>
> --
> You received this message because you are subscribed to the Google Groups
> "golang-nuts" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to golang-nuts+unsubscr...@googlegroups.com.
> For more options, visit https://groups.google.com/d/optout.
>

-- 
You received this message because you are subscribed to the Google Groups 
"golang-nuts" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to golang-nuts+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to