Hey Kaan,

That does indeed sound correct! If you could manage to reproduce this 
behaviour any time in future, or if anybody finds this thread who is 
experiencing a similar issue, it would be very helpful to get the issue 
logged with as much detail in the Public Issue Tracker for App Engine, that 
way we could work on fixing whatever seems to be the issue. Glad to hear 
you got a workaround with --noauth_local_webserver, though. 

Cheers

Nick
Cloud Platform Community Support

On Monday, September 12, 2016 at 7:45:45 PM UTC-4, Kaan Soral wrote:
>
> Hi
>
> Thanks for the reply
>
> This is the url I get: 
> https://accounts.google.com/o/oauth2/auth?scope=https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fappengine.admin+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fcloud-platform+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fuserinfo.email&redirect_uri=http%3A%2F%2Flocalhost%3A8080%2F&response_type=code&client_id=XXX.apps.googleusercontent.com&access_type=offline
>
> I use appcfg.py to deploy, I think it creates a temporary webserver for 
> deployments, which get stuck, this is my theory
>
> Some findings:
> 1) Shutting down the dev_appserver which natively uses 8080 port doesn't 
> solve the issue
> 2) The issue usually happens on re-deployments, when it happens, it 
> usually last 10 to 30 minutes
>
> I usually deploy in heat, sometimes a new deployment causes an issue, you 
> need to re-deploy fast, this issue steals a lot of precious time that would 
> otherwise be productive
>
> I was using the 1.9.36 SDK, switched to 1.9.40, I don't know whether it 
> fixes the issue
>
> In any case, I just tried `--noauth_local_webserver` - should've tried it 
> earlier, so my wasted time is on me
>
> I'm speculating there is a temporary webserver that just serves to take 
> that auth code from the browser and feed it into appcfg, that webserver 
> glitches a lot (at least it did on 1.9.36, I didn't get to test whether 
> things are same on 1.9.40)
>
> On Monday, September 12, 2016 at 10:30:36 PM UTC+3, Nick (Cloud Platform 
> Support) wrote:
>>
>> Hey Kaan,
>>
>> I think there's an unstated assumption here which is creating a bit of 
>> difficulty in getting to a consensus on the next steps. We don't expect 
>> that browser auth for gcloud should be redirecting to localhost:8080. You 
>> should be given a URL like the following:
>>
>>
>> https://accounts.google.com/o/oauth2/auth?redirect_uri=urn%3Aietf%3Awg%3Aoauth%3A2.0%3Aoob&prompt=select_account&response_type=code&client_id=12345678.apps.googleusercontent.com&scope=https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fuserinfo.email+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fcloud-platform+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fappengine.admin+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fcompute&access_type=offline
>>
>> In order to determine what's going on, since it's not quite clear really 
>> what's even going on, let alone why it might be going on, we'll need some 
>> precise technical details that can be given in a Public Issue Tracker 
>> <http://code.google.com/p/google-cloud-platform/issues/list> report as 
>> mentioned above. The precise code / commands relevant along with HAR 
>> recordings of the browser activity, or a tcp dump of the browser's activity 
>> during that time, should be sufficient.
>>
>> Let me know when you've made a Public Issue Tracker report so I can take 
>> a look at it right away, although of course we do aim to respond to threads 
>> as soon as possible and monitor the forums daily.
>>
>> Cheers,
>>
>> Nick
>> Cloud Platform Community Support
>>
>>
>> On Monday, September 12, 2016 at 4:42:02 AM UTC-4, Kaan Soral wrote:
>>>
>>> This started being a regular issue for me, now the auth's redirect to 
>>> :8090 - I'm using the port 8090 myself, the SDK uses the 8080
>>>
>>> The initial deployment usually works, but for re-deployments, I'm 
>>> usually hit by this issue :(
>>>
>>

-- 
You received this message because you are subscribed to the Google Groups 
"Google App Engine" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to google-appengine+unsubscr...@googlegroups.com.
To post to this group, send email to google-appengine@googlegroups.com.
Visit this group at https://groups.google.com/group/google-appengine.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/google-appengine/62099996-feae-4b38-92e9-2457de3adcf9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to