Hi Nicholas, thank you for your time!

I am indeed able to pull the image using the gcloud command. However, if I 
paste the exact same url as the --image-url option it throws the same error

`gcloud app deploy app.yaml --image-url "us.gcr.io/..."`

`ERROR: (gcloud.app.deploy) Error Response: [3] Docker image 
us.gcr.io/starchup-1472916020/appengine/default.20160922t203639:latest was 
either not found, or you do not have access to it.`

On Wednesday, September 21, 2016 at 4:38:25 PM UTC-5, Nicholas (Google 
Cloud Support) wrote:
>
> When getting the *pull* command from the Container Registry of the 
> Developers Console, can you then successfully deploy with *gcloud app 
> deploy* using the provided container URL with the *--image-url* option? 
>  Apologies if it seems like I'm asking you to repeat yourself but wish to 
> clarify if your success with the *pull* command is limited to said 
> command or if you can also now deploy with *gcloud app deploy* after 
> navigating to the directory.
>
> On Thursday, September 15, 2016 at 2:27:52 PM UTC-4, Geoffroy Lesage wrote:
>>
>> Nevermind I am able to pull it once I navigate inside the correct 
>> directory. Is there anything I can do with that image to help with this 
>> issue?
>>
>> On Thursday, September 15, 2016 at 10:46:10 AM UTC-5, Geoffroy Lesage 
>> wrote:
>>>
>>> Hi Nicholas,
>>>
>>> I am able to see it on the container Registry however I seem unable to 
>>> pull it...
>>>
>>>
>>> <https://lh3.googleusercontent.com/-zl7Yf8zqPog/V9rCI-P19AI/AAAAAAAABvo/vFeaJsaX2Sw7Pc8znXuK_Ppj5a9Bkg50wCLcB/s1600/container.png>
>>>
>>>
>>> I should mention that I deleted all versions except the latest under App 
>>> Engine --> Versions.. so there is only 1 version left
>>>
>>>
>>> <https://lh3.googleusercontent.com/-2lNYXSAm14s/V9rCNujJ6ZI/AAAAAAAABvs/EhKnIkOQcCIIjD8CFGfU7HOGWM9xUVHLgCLcB/s1600/version.png>
>>>
>>>
>>> On Wednesday, September 14, 2016 at 12:52:50 PM UTC-5, Nicholas (Google 
>>> Cloud Support) wrote:
>>>>
>>>> I have not yet been able to reproduce the issues you are reporting. 
>>>>  The container not found by the *gcloud app deploy* command, is it 
>>>> listing in your Container Registry under Container Engine?  Do you have 
>>>> full visibility over this registry?  Can you *pull 
>>>> <https://cloud.google.com/container-registry/docs/pulling>* it using 
>>>> the command provided by the Developers Console?
>>>>
>>>> On Monday, August 22, 2016 at 2:11:18 AM UTC-4, Nao Ito wrote:
>>>>>
>>>>> Hi,
>>>>> I have served one website with GCE(GAE flexible = vm).
>>>>> But suddenly the deployment command got to result in failure.
>>>>> I could deploy successfully with the same command about four months 
>>>>> ago.
>>>>>
>>>>> I googled the error code and message, but there is no related post at 
>>>>> all.
>>>>> Does anyone face the same error? or come up with some hints to solve 
>>>>> the problem?
>>>>>
>>>>> Thank you in advance.
>>>>>
>>>>>
>>>>> # Details
>>>>> ## Development Environment: Mac OS 10.11.6
>>>>>
>>>>> ## Development Language: Go (GAE/Go)
>>>>>
>>>>> ## Command: aedeploy gcloud preview app deploy app.yaml --promote
>>>>>
>>>>> ## Debug message(using option: --verbose debug):
>>>>> Updating module [default]...\DEBUG: Operation 
>>>>> [apps/project_id/operations/ab08cc84-9104-43db-9430-805fce9936a7] 
>>>>> complete. 
>>>>> Result: {
>>>>>     "metadata": {
>>>>>         "target": 
>>>>> "apps/project_id/modules/default/versions/20160821t144637",
>>>>>         "method": "google.appengine.v1beta4.Versions.CreateVersion",
>>>>>         "operationType": "create_version",
>>>>>     },
>>>>>     "done": true,
>>>>>     "name": 
>>>>> "apps/project_id/operations/ab08cc84-9104-43db-9430-805fce9936a7",
>>>>>     "error": {
>>>>>         "message": "Docker image 
>>>>> appengine.gcr.io/gcloud/project_id.version.time was either not found, 
>>>>> or you do not have access to it.",
>>>>>         "code": 3
>>>>>     }
>>>>> }
>>>>> Updating module [default]...failed.
>>>>>
>>>>>
>>>>>

-- 
You received this message because you are subscribed to the Google Groups 
"Google App Engine" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to google-appengine+unsubscr...@googlegroups.com.
To post to this group, send email to google-appengine@googlegroups.com.
Visit this group at https://groups.google.com/group/google-appengine.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/google-appengine/3a61579d-a970-4ccb-acd2-5ffa78919683%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to