http://gwt-code-reviews.appspot.com/291801/diff/1/6
File bikeshed/src/com/google/gwt/collections/MutableArray.java (right):

http://gwt-code-reviews.appspot.com/291801/diff/1/6#newcode97
bikeshed/src/com/google/gwt/collections/MutableArray.java:97: E[]
newElems = (E[]) new Object[oldLen + 1];
Inserts and removes still get faster because they no longer have to
allocate (most of the time).  They still have to copy, of course.  Also,
removal of the last element is a not uncommon thing to do (consider
implementing a stack using a list).

A more standard name for grow() would be setCapacity().

http://gwt-code-reviews.appspot.com/291801/show

--
http://groups.google.com/group/Google-Web-Toolkit-Contributors

To unsubscribe from this group, send email to 
google-web-toolkit-contributors+unsubscribegooglegroups.com or reply to this email with 
the words "REMOVE ME" as the subject.

Reply via email to