Thanks for the quick review!
http://gwt-code-reviews.appspot.com/809802/diff/1/2 File dev/core/src/com/google/gwt/core/ext/linker/impl/hosted.js (right): http://gwt-code-reviews.appspot.com/809802/diff/1/2#newcode45 dev/core/src/com/google/gwt/core/ext/linker/impl/hosted.js:45: function getHostedModeServer() { On 2010/08/28 00:12:56, jat wrote:
You should call this getCodeServer instead.
Done. Also changed some other stuff which doesn't need to be called "hosted" http://gwt-code-reviews.appspot.com/809802/diff/1/2#newcode262 dev/core/src/com/google/gwt/core/ext/linker/impl/hosted.js:262: function tryConnectingToV2Plugin(hostedServer, sessionId, url) { On 2010/08/28 00:12:56, jat wrote:
Why name it this way if we aren't supporting V1 plugins?
Whoops - left over from before, changed. http://gwt-code-reviews.appspot.com/809802/diff/1/2#newcode269 dev/core/src/com/google/gwt/core/ext/linker/impl/hosted.js:269: var hostedServer = getHostedModeServer(); On 2010/08/28 00:12:56, jat wrote:
codeServer instead.
Done. http://gwt-code-reviews.appspot.com/809802/diff/1/2#newcode308 dev/core/src/com/google/gwt/core/ext/linker/impl/hosted.js:308: loadIframe("http://gwt.google.com/missing-plugin"); On 2010/08/28 00:12:56, jat wrote:
This should actually have a trailing slash to avoid an extra redirect.
Done. http://gwt-code-reviews.appspot.com/809802/diff/1/3 File dev/core/src/com/google/gwt/core/linker/CrossSiteIframeTemplate.js (right): http://gwt-code-reviews.appspot.com/809802/diff/1/3#newcode85 dev/core/src/com/google/gwt/core/linker/CrossSiteIframeTemplate.js:85: // evaluating "external.gwtOnLoad". yay - done. On 2010/08/28 00:12:56, jat wrote:
I think the try/catch can be deleted now that we no longer support
legacy hosted
mode (window.external).
http://gwt-code-reviews.appspot.com/809802/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors
