Hi,

In fact, in my patch (here: http://gwt-code-reviews.appspot.com/1383802/), i
didn't want to add the provider.

I still think that it's best to only put the AbstractAsyncActivity. The
provider was a request from the issue itself but I don't think it's a good
idea.

My major concern is flow control. Right now, there is nothing that would
prevent from calling the methods of an Activity in a different order. On an
Activity object there's nothing that prevents from calling the start()
method after calling the onCancel() method. I think this is a good thing.
That way you can use the same Activity object several time.

Therefore, i think that this simple class (
http://gwt-code-reviews.appspot.com/1383802/diff/1/user/src/com/google/gwt/activity/shared/AbstractAsyncActivity.java?column_width=80)
should be the only thing added. (and remove the HasFailure interface).

In fact, i don't see a single case where I would want to run the same
Activity sometime in runAsync and sometime directly.

But again, it was my first patch, so I wanted to do what was requested in
the description of the issue even if I don't think it's a good thing.

Antoine.

-- 
http://groups.google.com/group/Google-Web-Toolkit-Contributors

Reply via email to