>> we already figured that out but were hesitant to share it in case ibm wanted to remove this loophole.
 
We added "minor_versions" key so that some of our advanced customers can use NFSv4.1 or even NFSv4.2.  I can assure you this would be available.
 
>> just had an include statement so we can edit another file locally instead of doing mmccr magic.
 
That would make config specific to a node, this might result in different nodes having a different config, possibly inconsistent. For example, one node supporting NFSv4.0 only and other supporting NFSv4.1 etc. The CCR magic is to make the config same on every node.
 
>> but can we assume that manually editing the ganesha.conf and pushing it to ccr is supported?
 
Officially not supported because you could edit in such a way that our CLI might not be able to parse the resulting file for applying further config updates. You should be fine as long as you follow the same rules as our CLI (don't use any comments etc).
 
Regards, Malahal.
----- Original message -----
From: Stijn De Weirdt <stijn.dewei...@ugent.be>
Sent by: gpfsug-discuss-boun...@spectrumscale.org
To: gpfsug-discuss@spectrumscale.org
Cc:
Subject: Re: [gpfsug-discuss] asking for your vote for an RFE to support NFS V4.1
Date: Mon, Mar 12, 2018 3:31 PM
 
hi malahal,

we already figured that out but were hesitant to share it in case ibm
wanted to remove this loophole.

but can we assume that manuanlly editing the ganesha.conf and pushing it
to ccr is supported?
the config file is heavily edited / rewritten when certain mm commands,
so we want to make sure we can always do this.

it would be even better if the main.conf that is generated/edited by the
ccr commands just had an include statement so we can edit another file
locally instead of doing mmccr magic.

stijn

On 03/12/2018 10:54 AM, Malahal R Naineni wrote:
> Upstream Ganesha code allows all NFS versions including NFSv4.2. Most Linux
> clients were defaulting to NFSv4.0, but now they started using NFS4.1 which IBM
> doesn't support. To avoid people accidentally using NFSv4.1, we decided to
> remove it by default.
> We don't support NFSv4.1, so there is no spectrum command to enable NFSv4.1
> support with PTF6. Of course, if you are familiar with mmccr, you can change the
> config and let it use NFSv4.1 but any issues with NFS4.1 will go to /dev/null. :-)
> You need to add "minor_versions = 0,1;" to NFSv4{} block
> in /var/mmfs/ces/nfs-config/gpfs.ganesha.main.conf to allow NFSv4.0 and NFsv4.1,
> and make sure you use mmccr command to make this change permanent.
> Regards, Malahal.
>
>     ----- Original message -----
>     From: Stijn De Weirdt <stijn.dewei...@ugent.be>
>     Sent by: gpfsug-discuss-boun...@spectrumscale.org
>     To: gpfsug-discuss@spectrumscale.org
>     Cc:
>     Subject: Re: [gpfsug-discuss] asking for your vote for an RFE to support NFS
>     V4.1
>     Date: Fri, Mar 9, 2018 6:13 PM
>     hi all,
>
>     i would second this request to upvote this. the fact that 4.1 support
>     was dropped in a subsubminor update (4.2.3.5 to 4.3.26 afaik) was
>     already pretty bad to discover, but at the very least there should be an
>     option to reenable it.
>
>     i'm also interested why this was removed (or actively prevented to
>     enable). i can understand that eg pnfs is not support, bu basic protocol
>     features wrt HA are a must have.
>     only with 4.1 are we able to do ces+ganesha failover without IO error,
>     something that should be basic feature nowadays.
>
>     stijn
>
>     On 03/09/2018 01:21 PM, Engeli  Willi (ID SD) wrote:
>      > Hello Group,
>      >
>      > I’ve just created a request for enhancement (RFE) to have ganesha supporting
>      > NFS V4.1.
>      >
>      > It is important, to have this new Protocol version supported, since our
>      > Linux clients default support is more then 80% based in this version by
>      > default and Linux distributions are actively pushing this Protocol.
>      >
>      > The protocol also brings important corrections and enhancements with it.
>      >
>      >
>      >
>      > I would like to ask you all very kindly to vote for this RFE please.
>      >
>      > You find it here: https://www.ibm.com/developerworks/rfe/execute
>      >
>      > Headline:NFS V4.1 Support
>      >
>      > ID:117398
>      >
>      >
>      >
>      >
>      >
>      > Freundliche Grüsse
>      >
>      >
>      >
>      > Willi Engeli
>      >
>      > ETH Zuerich
>      >
>      > ID Speicherdienste
>      >
>      > Weinbergstrasse 11
>      >
>      > WEC C 18
>      >
>      > 8092 Zuerich
>      >
>      >
>      >
>      > Tel: +41 44 632 02 69
>      >
>      >
>      >
>      >
>      >
>      >
>      > _______________________________________________
>      > gpfsug-discuss mailing list
>      > gpfsug-discuss at spectrumscale.org
>      >
>     https://urldefense.proofpoint.com/v2/url?u=http-3A__gpfsug.org_mailman_listinfo_gpfsug-2Ddiscuss&d=DwIF-g&c=jf_iaSHvJObTbx-siA1ZOg&r=oaQVLOYto6Ftb8wAbynvIiIdh2UEjHxQByDz70-6a_0&m=yq4xoVKCPWQTqZVp0BgG8fBpXrS2FehGlAua1Eixci4&s=9DJi6qkF4eRc81vv6SlC3gxKL9oJJ4efkktzNaZAnkA&e=
>      >
>     _______________________________________________
>     gpfsug-discuss mailing list
>     gpfsug-discuss at spectrumscale.org
>     https://urldefense.proofpoint.com/v2/url?u=http-3A__gpfsug.org_mailman_listinfo_gpfsug-2Ddiscuss&d=DwIF-g&c=jf_iaSHvJObTbx-siA1ZOg&r=oaQVLOYto6Ftb8wAbynvIiIdh2UEjHxQByDz70-6a_0&m=yq4xoVKCPWQTqZVp0BgG8fBpXrS2FehGlAua1Eixci4&s=9DJi6qkF4eRc81vv6SlC3gxKL9oJJ4efkktzNaZAnkA&e=
>
>
>
>
> _______________________________________________
> gpfsug-discuss mailing list
> gpfsug-discuss at spectrumscale.org
> https://urldefense.proofpoint.com/v2/url?u=http-3A__gpfsug.org_mailman_listinfo_gpfsug-2Ddiscuss&d=DwIGaQ&c=jf_iaSHvJObTbx-siA1ZOg&r=oaQVLOYto6Ftb8wAbynvIiIdh2UEjHxQByDz70-6a_0&m=JnhkpdKKCp1F9me7Egfx1CIwYQ1MTXGh4CH_dAW2JaE&s=j2540eKxrXTWXII3ddKZaPR2ST6u7OaGKs1JTb-Ad3c&e=
>
_______________________________________________
gpfsug-discuss mailing list
gpfsug-discuss at spectrumscale.org
https://urldefense.proofpoint.com/v2/url?u=http-3A__gpfsug.org_mailman_listinfo_gpfsug-2Ddiscuss&d=DwIGaQ&c=jf_iaSHvJObTbx-siA1ZOg&r=oaQVLOYto6Ftb8wAbynvIiIdh2UEjHxQByDz70-6a_0&m=JnhkpdKKCp1F9me7Egfx1CIwYQ1MTXGh4CH_dAW2JaE&s=j2540eKxrXTWXII3ddKZaPR2ST6u7OaGKs1JTb-Ad3c&e=

 
 

_______________________________________________
gpfsug-discuss mailing list
gpfsug-discuss at spectrumscale.org
http://gpfsug.org/mailman/listinfo/gpfsug-discuss

Reply via email to