#3392: t.register: encoding error
--------------------------+---------------------------------
  Reporter:  mlennert     |      Owner:  grass-dev@…
      Type:  defect       |     Status:  new
  Priority:  normal       |  Milestone:  7.2.2
 Component:  Temporal     |    Version:  svn-trunk
Resolution:               |   Keywords:  t.register encoding
       CPU:  Unspecified  |   Platform:  Unspecified
--------------------------+---------------------------------

Comment (by zarch):

 Replying to [comment:1 zarch]:
 > Replying to [ticket:3392 mlennert]:
 > > Using the data and examples from [http://ncsu-geoforall-lab.github.io
 /grass-temporal-workshop/ 1] in a french (fr_BE@UTF-8) encoding
 environment, I get an encoding error using t.register:
 >
 > I was able to reproduce the error, actually the #3394, and with the
 attached patch is working on my PC.
 > Can you test it?

 I remembered that once Glynn in grass-dev (2016-05-05) said:

 ''"Anything using the script module should be using byte strings
 throughout (in spite of how awkward Python 3 tries to make this)."''

 So I think that instead of returning unicode as I did in the first patch
 we should return bytes...
 Please apply the two diff files, and let me know if it is working for you.

--
Ticket URL: <https://trac.osgeo.org/grass/ticket/3392#comment:2>
GRASS GIS <https://grass.osgeo.org>

_______________________________________________
grass-dev mailing list
grass-dev@lists.osgeo.org
https://lists.osgeo.org/mailman/listinfo/grass-dev

Reply via email to