#3392: t.register: encoding error
--------------------------+---------------------------------
  Reporter:  mlennert     |      Owner:  grass-dev@…
      Type:  defect       |     Status:  new
  Priority:  normal       |  Milestone:  7.2.2
 Component:  Temporal     |    Version:  svn-trunk
Resolution:               |   Keywords:  t.register encoding
       CPU:  Unspecified  |   Platform:  Unspecified
--------------------------+---------------------------------

Comment (by zarch):

 Replying to [comment:4 mlennert]:
 > Replying to [comment:2 zarch]:
 > > So I think that instead of returning unicode as I did in the first
 patch we should return bytes...
 > > Please apply the two diff files, and let me know if it is working for
 you.
 >
 > I've applied your patches (BTW: it is always best to make diffs relative
 to the source tree root. That way one doesn't have to search for where the
 patched files are...).

 Ops, sorry I did not notice that the diff was sensitive to my current
 working directory.

 \\


 > t.info (#3394) and t.rast.extract (#3395) now work, but I suspect that
 the errors there came from the accent in the description of the strds.

 Indeed the error was due to `é` character in the description. I was able
 to reproduce only the error with `t.info`. I added a test r71391.

 \\

 I'm not able to reproduce these errors in: `t.create`, `t.register`,
 `t.unregister`, `t.remove`.

 I executed the testsuite in `grass/lib/python/temporal` and
 `grass/temporal` with no regressions.
 But, since I was able to reproduce only the `t.info` error, it would be
 nice, before do the commit, to add tests in: t.create, t.register,
 t.unregister, t.remove that problem.

 At the moment I'm not able to write the tests for them, someone can help
 me?

--
Ticket URL: <https://trac.osgeo.org/grass/ticket/3392#comment:5>
GRASS GIS <https://grass.osgeo.org>

_______________________________________________
grass-dev mailing list
grass-dev@lists.osgeo.org
https://lists.osgeo.org/mailman/listinfo/grass-dev

Reply via email to