Howdy Pierre!

In my experience, the GeoPat modules need to know where several things
are located, including (I think) parts of the GRASS source code. Have
a look through the install.sh code:

http://sil.uc.edu/gitlist/geoPAT/blob/stable/install.sh

I was able to get these modules up and running by invoking install.sh like this:

sh install.sh grass75

... where "grass75" is the binary compiled from grass_trunk. The
install.sh code seemed to find the source code it needed and worked
without issue.

How did you install / upgrade the Geopat modules? Could it be that
install.sh is "finding" the old source code / headers? Is there a
package for both GRASS binaries and development files?

Dylan


On Thu, Feb 22, 2018 at 7:28 PM, Pierre Roudier
<pierre.roud...@gmail.com> wrote:
> Hi,
>
> I've been compiling the geoPAT extensions for GRASS from
> http://sil.uc.edu/gitlist/geoPAT/
>
> At the time I was running GRASS 7.2.2 installed from the Ubuntu GIS
> repository, but since this repo updated to GRASS 7.4, I have the following
> issue:
>
> GRASS 7.4.0 (modis_lst_2015):~ > p.sig.polygons --help
> ERROR: Module built against version $Revision: 70617 $ but trying to use
>        version $Revision: 70829 $. You need to rebuild GRASS GIS or
>        untangle multiple installations.
> [Raster MASK present]
>
> Any pointers about how to resolve the version tangling? I've tried
> recompiling geoPAT, but that didn't work.
>
> Cheers,
>
> Pierre
>
> _______________________________________________
> grass-dev mailing list
> grass-dev@lists.osgeo.org
> https://lists.osgeo.org/mailman/listinfo/grass-dev
_______________________________________________
grass-dev mailing list
grass-dev@lists.osgeo.org
https://lists.osgeo.org/mailman/listinfo/grass-dev

Reply via email to