Dear Markus,
I followed the instruction in
https://copr.fedorainfracloud.org/coprs/neteler/grass72/.  I still get the
same errors I posted above. The latest gdal I can install from epel repo is
version 1.11.4. If it help, the centos version I am using is the latest
available image on google cloud compute (CentOS, CentOS, 7, x86_64 built on
2017-07-19).

Thanks a lot

Laura



On 8 August 2017 at 23:43, Markus Neteler <nete...@osgeo.org> wrote:

> Hi Laura,
>
> On Fri, Jul 21, 2017 at 12:51 PM, Laura Poggio <laura.pog...@gmail.com>
> wrote:
> > Dear all,
> > I am trying to install GRASS 7.2.1 using the repository neteler-grass72
> on a
>
> This one:
> https://copr.fedorainfracloud.org/coprs/neteler/grass72/
>
> > machine running centos 7 [Linux version 3.10.0-514.26.2.el7.x86_64
> > (buil...@kbuilder.dev.centos.org) (gcc version 4.8.5 20150623 (Red Hat
> > 4.8.5-11) (GCC) )]
> >
> > I get the following errors:
> > Error: Package: grass-libs-7.2.1-6.fc26.x86_64 (neteler-grass72)
> >            Requires: libproj.so.12()(64bit)
> > Error: Package: grass-libs-7.2.1-6.fc26.x86_64 (neteler-grass72)
> >            Requires: libm.so.6(GLIBC_2.23)(64bit)
> > Error: Package: grass-libs-7.2.1-6.fc26.x86_64 (neteler-grass72)
> >            Requires: libgdal.so.20()(64bit)
> > Error: Package: grass-libs-7.2.1-6.fc26.x86_64 (neteler-grass72)
> >            Requires: libcrypto.so.1.1()(64bit)
> > Error: Package: grass-libs-7.2.1-6.fc26.x86_64 (neteler-grass72)
> >            Requires: libpng16.so.16()(64bit)
> > Error: Package: grass-libs-7.2.1-6.fc26.x86_64 (neteler-grass72)
> >            Requires: libpng16.so.16(PNG16_0)(64bit)
> > Error: Package: grass-libs-7.2.1-6.fc26.x86_64 (neteler-grass72)
> >            Requires: libgeos-3.6.1.so()(64bit)
> > Error: Package: grass-libs-7.2.1-6.fc26.x86_64 (neteler-grass72)
> >            Requires: libssl.so.1.1()(64bit)
> >
> > As far as I can see it requires versions of the libraries that are not
> > readily available from centos 7 repositories (including epel).
>
> I have compiled the version in July on COPR.
> https://copr.fedorainfracloud.org/coprs/neteler/grass72/builds/
>
> Did you install beforehand
>
> yum install epel-release
> yum install gdal gdal-python gdal-devel
> ?
>
>
> > I could compile grass 7.2.1 from source without problems, but I would
> prefer
> > to use the repository if at all possible.
> > What am I missing ? Do I need to compile the dependencies before in
> order to
> > have the right versions? Are there any repositories where the rmps could
> be
> > found?
>
> Those two above should deliver the needed proj and gdal RPMs.
>
> Best
> Markus
>
> --
> Markus Neteler, PhD
> http://www.mundialis.de - free data with free software
> http://grass.osgeo.org
> http://courses.neteler.org/blog
>
_______________________________________________
grass-user mailing list
grass-user@lists.osgeo.org
https://lists.osgeo.org/mailman/listinfo/grass-user

Reply via email to