Thank you for your reply Jochen, but it isn't working yet. 

As you said, i changed my web_endpoint_uri and nothing happened. I've tried 
every possible configuration i found and nothing works. I simply can't find 
whats wrong with the server. Yesterday i found out that the elasticsearch 
server wasn't working as expected, and then i fixed it, but my problem 
persists. I don't even know what to search for in my log file.

Em terça-feira, 20 de setembro de 2016 18:25:21 UTC-3, Jochen Schalanda 
> Hi Wesley,
> your rest_transport_uri 
> <>
> setting is wrong. Either leave it completely out (so that the default is 
> being used; in this case you have to set web_endpoint_uri 
> <>
> accordingly) or change it to http://hom.example/graylog/api/ (guessing 
> from your Apache httpd configuration).
> Cheers,
> Jochen
> On Tuesday, 20 September 2016 20:04:41 UTC+2, Wesley Pallete de Sousa 
> wrote:
>> Hello guys!
>> I'm working with Graylog 2.1 in my server, but i can't access the web 
>> interface. For the last two days i have been looking for answers without 
>> success. I started the server in debug mode and everything is working (in 
>> theory), but i can't access the 9000 port. I just don't understand what is 
>> happening. I tried to configure the apache virtualhost just like the docs 
>> example and there is no access change. Everything is configured just like 
>> the docs. The only difference here is that i'm using the server under a 
>> subdomain, not the ip. I need some help on this.
>> Apache VirtualHost
>> <VirtualHost *:80>
>>   ServerName hom.example
>>   DocumentRoot /var/www/www-root
>>   AddCharset UTF-8 .utf8
>>   ErrorLog /var/log/apache2/hom.error.log
>>   CustomLog /var/log/apache2/hom.access.log combined
>>   <Directory "/var/www/www-root">
>>     Options FollowSymLinks MultiViews
>>     AllowOverride All
>>     Require all granted
>>   </Directory>
>>     ProxyRequests Off
>>     <Proxy "*">
>>         Require all granted
>>     </Proxy>
>>     <Location "/graylog">
>>         RequestHeader set X-Graylog-Server-URL "
>> http://hom.example/graylog/api/ 
>> <>
>> "
>>         ProxyPass
>>         ProxyPassReverse
>>     </Location>
>> </VirtualHost>
>> Graylog Config (Just what i changed many times)
>> rest_listen_uri =
>> rest_transport_uri =
>> web_listen_uri =
>> web_enable = true
>> The connection to mongodb is working fine, just like the connection to 
>> elasticsearch. In theory it should work but i can't access any configured 
>> uri.
>> There are several virtualhost in my server, and i don't have access to 
>> create a new subdomain, like graylog.mydomain. That's why i'm trying to 
>> configure it under http://hom.example/graylog or 
>> http://hom.example:9000/api/.
>> Sorry for my bad english, is just that i don't practice. Any help is 
>> welcome.
>> Thanks in advance.

You received this message because you are subscribed to the Google Groups 
"Graylog Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
To view this discussion on the web visit
For more options, visit

Reply via email to