Last week, while working on another project, I moved all of the fonts which had been installed in my user directory (~/Library/Fonts) to the system directory (/Library/Fonts) because Inkscape can see fonts in the latter but not the former.

Today, in working on the 4.2 release I tried to compile the docs and got an error about font loading. Reducing to a minimal example (see attached), I get the following error when compiling with TeXLive 2015:


This is LuaTeX, Version beta-0.80.0 (TeX Live 2015) (rev 5238)
 \write18 enabled.
(./Main.tex
LaTeX2e <2016/03/31>
Babel <3.9q> and hyphenation patterns for 1 language(s) loaded.
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/article.cls
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/size10.clo))
(/usr/local/texlive/2015/texmf-dist/tex/latex/fontspec/fontspec.sty
(/usr/local/texlive/2015/texmf-dist/tex/latex/l3kernel/expl3.sty
(/usr/local/texlive/2015/texmf-dist/tex/latex/l3kernel/expl3-code.tex)
(/usr/local/texlive/2015/texmf-dist/tex/latex/l3kernel/l3pdfmode.def))
(/usr/local/texlive/2015/texmf-dist/tex/latex/l3packages/xparse/xparse.sty)
(/usr/local/texlive/2015/texmf-dist/tex/luatex/luaotfload/luaotfload.sty(using w
rite cache: /Users/RPS/Library/texlive/2015/texmf-var/luatex-cache/generic)(usin
g read cache: /usr/local/texlive/2015/texmf-var/luatex-cache/generic /Users/RPS/
Library/texlive/2015/texmf-var/luatex-cache/generic)tput: No value for $TERM 
and no -T specified

luaotfload | main : initialization completed in 0.322 seconds)
(/usr/local/texlive/2015/texmf-dist/tex/latex/fontspec/fontspec-luatex.sty
(/usr/local/texlive/2015/texmf-dist/tex/latex/base/fontenc.sty
(/usr/local/texlive/2015/texmf-dist/tex/latex/euenc/eu2enc.def)
(/usr/local/texlive/2015/texmf-dist/tex/latex/euenc/eu2lmr.fd)
/usr/local/texlive/2015/texmf-dist/tex/latex/base/fontenc.sty:105: Font \EU2/lmr
/m/n/10=file:lmroman10-regular:script=latn;+trep;+tlig; at 10pt not loadable: me
tric data not found or bad.
<to be read again>
relax
l.105 \fontencoding\encodingdefault\selectfont

?
Process aborted

When processing with TeXLive 2016, the error goes away and the document compiles fine.

Given the work I did on the fonts last week, I figured it must be an issue with the font caches and tried `luaotfload-tool --cache=erase` and `fc-config --really-force`, both to no avail. Does anyone have any other ideas as to what I might try to fix this problem (short of restoring my fonts directories to their state before I messed with them last week)?


--
✝✝✝✝✝✝✝✝✝✝✝✝✝✝✝✝✝✝✝✝✝✝✝✝✝
Br. Samuel, OSB
St. Anselm’s Abbey
Washington, DC
(R. Padraic Springuel)

PAX ☧ ΧΡΙΣΤΟΣ

Attachment: Main.tex
Description: TeX document

_______________________________________________
Gregorio-devel mailing list
Gregorio-devel@gna.org
https://mail.gna.org/listinfo/gregorio-devel

Répondre à