This bug was fixed in the package click-reviewers-tools - 0.44~16.04.1

---------------
click-reviewers-tools (0.44~16.04.1) xenial-proposed; urgency=medium

  [ Jamie Strandboge ]
  * data/apparmor-easyprof-ubuntu.json:
    - add pulseaudio interface
    - add bluetooth policy group for Touch for 15.04 and higher
    - add location-observe and location-control
    - move all core interfaces to 'common'
    - add gsettings interface
    - set home to auto-approve
    - add mpris interface
    - add camera interface
    - add optical-drive interface
    - add serial-port interface
    - add content interface
  * clickreviews/common.py:
    - don't fail on libmvec.so since it comes from libc6 too (LP: #1584346)
    - extend the regex to also match ld-linux-x86-64.so.2
  * sr_common.py:
    - update _verify_pkgname() and _verify_appname() to use the same regex as
      in snapd and various tests
    - update attributes to be slots or plugs side and cleanup code for
      specifying attributes
  * bin/click-review, clickreviews/modules.py: exit '1' if error with
    init_object or running checks
  * sr_lint.py:
    - support 'environment' key in yaml (LP: #1583259)
    - support 'confinement' key in yaml
  * sr_security.py:
    - specifying mpris slot should not warn
    - adjust profile name length checks to use series 16 security label format
  * run_tests: exit non-zero with failures, errors or unexpectedSuccesses
  * cr_lint.py:
    - 'puritine' is a known, but redflagged hook
    - skip external symlinks and md5sums checks for puritine (since we expect
      external symlinks and the hash checks fail on broken symlinks)
    - 'puritine' hook should not be used with 'apparmor'
  * clickreviews/apparmor_policy.py: adjust for rename of store team
    (LP: #1608943)

  [ Celso Providelo ]
  * support for interface abbreviated syntax (LP: #1595184)

 -- Jamie Strandboge <ja...@ubuntu.com>  Tue, 02 Aug 2016 08:43:31 -0500

** Changed in: click-reviewers-tools (Ubuntu Xenial)
       Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of नेपाली
भाषा समायोजकहरुको समूह, which is subscribed to Xenial.
Matching subscriptions: Ubuntu 16.04 Bugs
https://bugs.launchpad.net/bugs/1584346

Title:
  Store reports "package contains external symlinks: usr/lib/x86_64
  -linux-gnu/libmvec.so lint-snap-v2_external_symlinks"

Status in Canonical Click Reviewers tools:
  Fix Released
Status in click-reviewers-tools package in Ubuntu:
  Fix Released
Status in click-reviewers-tools source package in Xenial:
  Fix Released
Status in click-reviewers-tools source package in Yakkety:
  Fix Released

Bug description:
  [Impact] 
  This is already fixed in the store so the SRU is for users to not see this 
failure their local system.

  [Test Case]
  A test case was added for this, but a real world test is to grab shadowsock 
from https://myapps.developer.ubuntu.com/dev/click-apps/4485/rev/2/ and run the 
tool on it:

  $ snap-review /tmp/K51DuljGLGTBCESdYGXcuVymEPeyLI2S_2.snap
  /tmp/K51DuljGLGTBCESdYGXcuVymEPeyLI2S_2.snap: pass

  [Regression Potential] 
  Regression potential is extremely low since this is already on production in 
the Ubuntu Store for many weeks.

  
  = Original description =
  I think this bug is an issue of the ubuntu store, if this is not the correct 
project to report to, please re-assign to the correct one.

  When I upload my package to the store, it reports this failure:
  package contains external symlinks: usr/lib/x86_64-linux-gnu/libmvec.so 
lint-snap-v2_external_symlinks

  But ubuntu-core has the necessary file:

  $ ls -l /snap/ubuntu-core/current/lib/x86_64-linux-gnu/libmvec*
  -rw-r--r-- 1 root root 166368 Apr 15 06:16 
/snap/ubuntu-core/current/lib/x86_64-linux-gnu/libmvec-2.23.so
  lrwxrwxrwx 1 root root     15 Apr 15 06:16 
/snap/ubuntu-core/current/lib/x86_64-linux-gnu/libmvec.so.1 -> libmvec-2.23.so

  This is in my snap:

  $  ls -l /snap/shadowsocks/current/usr/lib/x86_64-linux-gnu/libmvec.so*
  lrwxrwxrwx 1 root root 34 Apr 15 06:17 
/snap/shadowsocks/current/usr/lib/x86_64-linux-gnu/libmvec.so -> 
/lib/x86_64-linux-gnu/libmvec.so.1

  /lib/x86_64-linux-gnu/libmvec.so.1 was not in a previous version of
  ubuntu-core, so I wonder if this failure is due to the check in ubuntu
  store is not up-to-date?

To manage notifications about this bug go to:
https://bugs.launchpad.net/click-reviewers-tools/+bug/1584346/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~group.of.nepali.translators
Post to     : group.of.nepali.translators@lists.launchpad.net
Unsubscribe : https://launchpad.net/~group.of.nepali.translators
More help   : https://help.launchpad.net/ListHelp

Reply via email to