** Tags removed: patch

** Changed in: bluez (Ubuntu Xenial)
       Status: New => Won't Fix

** Changed in: bluez (Ubuntu Artful)
     Assignee: (unassigned) => Dariusz Gadomski (dgadomski)

-- 
You received this bug notification because you are a member of नेपाली
भाषा समायोजकहरुको समूह, which is subscribed to Xenial.
Matching subscriptions: Ubuntu 16.04 Bugs
https://bugs.launchpad.net/bugs/1674680

Title:
  Deprecated rfcomm.conf still mentioned in bluetooth.conf and README

Status in bluez package in Ubuntu:
  Fix Released
Status in bluez source package in Xenial:
  Won't Fix
Status in bluez source package in Yakkety:
  Won't Fix
Status in bluez source package in Artful:
  Fix Released
Status in bluez package in Debian:
  New

Bug description:
  [Impact]

   * The package contains misleading documentation mentioning the use of
  /etc/bluetooth/rfcomm.conf for rfcomm setup while the support for
  config file has been dropped after 14.04 release. I have directly
  received a question about it from a user mislead by the documentation.

  * Additionally deprecated -f option is still used in legacy upstart
  /etc/init/bluetooth.conf. Actually this does not seem longer required
  due to upstart being removed.

  [Test Case]

   * Install bluez.

   * Look for misleading rfcomm.conf mentions in
  /etc/init/bluetooth.conf, /usr/share/doc/bluez/README.Debian.gz

  [Regression Potential]

   * This is mostly a documentation correction, however if somebody
  still depends bluetooth started with Ubuntu 16.04+ by upstart (or
  possibly some kind of upstart compatibility in systemd, is that even
  possible?) he/she may end up with bluetooth not being started. This
  seems highly unlikely.

  [Other Info]

   * Original bug description:

  Support for config files has been dropped upstream in 2012 (however
  version shipped with Trusty still supports it), but the latest
  versions (including Xenial and Zesty) still mention it in the docs and
  in the legacy /etc/init/bluetooth.conf file.

  Additionally the /etc/init/bluetooth.conf don't seem necessary these
  days. In fact it has been dropped by Debian already.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1674680/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~group.of.nepali.translators
Post to     : group.of.nepali.translators@lists.launchpad.net
Unsubscribe : https://launchpad.net/~group.of.nepali.translators
More help   : https://help.launchpad.net/ListHelp

Reply via email to