Change is in >=v2.3.0 which makes this Fix released for a while.
Lets add and consider SRU from there.

** Also affects: libvirt (Ubuntu Xenial)
   Importance: Undecided
       Status: New

** Changed in: libvirt (Ubuntu)
       Status: New => Fix Released

-- 
You received this bug notification because you are a member of नेपाली
भाषा समायोजकहरुको समूह, which is subscribed to Xenial.
Matching subscriptions: Ubuntu 16.04 Bugs
https://bugs.launchpad.net/bugs/1709877

Title:
  CPU hotplug fails in the system with empty numa nodes, "Invalid value
  '0-1,16-17' for 'cpuset.mems': Invalid argument"

Status in libvirt package in Ubuntu:
  Fix Released
Status in libvirt source package in Xenial:
  New

Bug description:
  == Comment: #0 - Satheesh Rajendran <sathe...@in.ibm.com> - 2017-07-19 
04:13:18 ==
  CPU hotplug operation fails in the host with empty numa nodes(with no memory) 
even though VM placement is static and with/without numad is running.
  ..
   <vcpu placement='static' current='4'>32</vcpu>
  ...

  
  # virsh setvcpus virt-tests-vm1 6 --live
  error: Invalid value '0-1,16-17' for 'cpuset.mems': Invalid argument

  
  # numactl --hardware
  available: 4 nodes (0-1,16-17)
  node 0 cpus: 0 8 16 24 32 40
  node 0 size: 16188 MB
  node 0 free: 1119 MB
  node 1 cpus: 48 56 64 72 80 88
  node 1 size: 32630 MB
  node 1 free: 13233 MB
  node 16 cpus: 96 104 112 120 128 136
  node 16 size: 0 MB
  node 16 free: 0 MB
  node 17 cpus: 144 152 160 168 176 184
  node 17 size: 0 MB
  node 17 free: 0 MB
  node distances:
  node   0   1  16  17 
    0:  10  20  40  40 
    1:  20  10  40  40 
   16:  40  40  10  20 
   17:  40  40  20  10 

  # cat /sys/fs/cgroup/cpuset/cpuset.mems 
  0-1

  Host:
  #uname -a
  Linux powerkvm4-lp1 4.10.0-27-generic #30~16.04.2-Ubuntu SMP Thu Jun 29 
16:06:52 UTC 2017 ppc64le ppc64le ppc64le GNU/Linux

  ii  libvirt-bin                            1.3.1-1ubuntu10.11 
  ii  numad                                  0.5+20150602-4 
  qemu-kvm                               1:2.5+dfsg-5ubuntu10.14

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libvirt/+bug/1709877/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~group.of.nepali.translators
Post to     : group.of.nepali.translators@lists.launchpad.net
Unsubscribe : https://launchpad.net/~group.of.nepali.translators
More help   : https://help.launchpad.net/ListHelp

Reply via email to