** Also affects: qemu (Ubuntu Zesty)
   Importance: Undecided
       Status: New

** Also affects: linux (Ubuntu Zesty)
   Importance: Undecided
       Status: New

** Also affects: qemu (Ubuntu Xenial)
   Importance: Undecided
       Status: New

** Also affects: linux (Ubuntu Xenial)
   Importance: Undecided
       Status: New

** Changed in: linux (Ubuntu Xenial)
       Status: New => In Progress

** Changed in: linux (Ubuntu Zesty)
       Status: New => In Progress

** Changed in: qemu (Ubuntu Xenial)
       Status: New => Won't Fix

** No longer affects: qemu (Ubuntu Zesty)

** No longer affects: qemu (Ubuntu Xenial)

** Changed in: linux (Ubuntu Xenial)
   Importance: Undecided => Critical

** Changed in: linux (Ubuntu Zesty)
   Importance: Undecided => Critical

** Changed in: linux (Ubuntu)
       Status: New => In Progress

** Changed in: linux (Ubuntu Xenial)
     Assignee: (unassigned) => Joseph Salisbury (jsalisbury)

** Changed in: linux (Ubuntu Zesty)
     Assignee: (unassigned) => Joseph Salisbury (jsalisbury)

-- 
You received this bug notification because you are a member of नेपाली
भाषा समायोजकहरुको समूह, which is subscribed to Xenial.
Matching subscriptions: Ubuntu 16.04 Bugs
https://bugs.launchpad.net/bugs/1709784

Title:
  KVM on 16.04.3 throws an error

Status in The Ubuntu-power-systems project:
  New
Status in linux package in Ubuntu:
  In Progress
Status in qemu package in Ubuntu:
  Won't Fix
Status in linux source package in Xenial:
  In Progress
Status in linux source package in Zesty:
  In Progress

Bug description:
  Problem Description
  ====================
  KVM on Ubuntu 16.04.3 throws an error when used
   
  ---uname output---
  Linux bastion-1 4.4.0-89-generic #112-Ubuntu SMP Mon Jul 31 19:37:08 UTC 2017 
ppc64le ppc64le ppc64le GNU/Linux
   
  Machine Type =  8348-21C Habanero 
   
  ---Steps to Reproduce---
   Install 16.04.3

  install KVM like:

  apt-get install libvirt-bin qemu qemu-slof qemu-system qemu-utils

  then exit and log back in so virsh will work without sudo

  then run my spawn script

  $ cat spawn.sh
  #!/bin/bash

  img=$1
  qemu-system-ppc64 \
  -machine pseries,accel=kvm,usb=off -cpu host -m 512 \
  -display none -nographic \
  -net nic -net user \
  -drive "file=$img"

  with a freshly downloaded ubuntu cloud image

  sudo ./spawn.sh xenial-server-cloudimg-ppc64el-disk1.img

  And I get nothing on the output.

  and errors in dmesg

  
  ubuntu@bastion-1:~$ [  340.180295] Facility 'TM' unavailable, exception at 
0xd0000000148b7f10, MSR=9000000000009033
  [  340.180399] Oops: Unexpected facility unavailable exception, sig: 6 [#1]
  [  340.180513] SMP NR_CPUS=2048 NUMA PowerNV
  [  340.180547] Modules linked in: xt_CHECKSUM iptable_mangle ipt_MASQUERADE 
nf_nat_masquerade_ipv4 iptable_nat nf_nat_ipv4 nf_nat nf_conntrack_ipv4 
nf_defrag_ipv4 xt_conntrack nf_conntrack ipt_REJECT nf_reject_ipv4 xt_tcpudp 
bridge stp llc ebtable_filter ebtables ip6table_filter ip6_tables 
iptable_filter ip_tables x_tables kvm_hv kvm binfmt_misc joydev input_leds 
mac_hid opal_prd ofpart cmdlinepart powernv_flash ipmi_powernv ipmi_msghandler 
mtd at24 uio_pdrv_genirq uio ibmpowernv powernv_rng vmx_crypto ib_iser rdma_cm 
iw_cm ib_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi 
scsi_transport_iscsi autofs4 btrfs raid10 raid456 async_raid6_recov 
async_memcpy async_pq async_xor async_tx xor raid6_pq raid1 raid0 multipath 
linear mlx4_en hid_generic usbhid hid uas usb_storage ast i2c_algo_bit bnx2x 
ttm drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops mlx4_core drm 
ahci vxlan libahci ip6_udp_tunnel udp_tunnel mdio libcrc32c
  [  340.181331] CPU: 46 PID: 5252 Comm: qemu-system-ppc Not tainted 
4.4.0-89-generic #112-Ubuntu
  [  340.181382] task: c000001e34c30b50 ti: c000001e34ce4000 task.ti: 
c000001e34ce4000
  [  340.181432] NIP: d0000000148b7f10 LR: d000000014822a14 CTR: 
d0000000148b7e40
  [  340.181475] REGS: c000001e34ce77b0 TRAP: 0f60   Not tainted  
(4.4.0-89-generic)
  [  340.181519] MSR: 9000000000009033 <SF,HV,EE,ME,IR,DR,RI,LE>  CR: 22024848  
XER: 00000000
  [  340.181629] CFAR: d0000000148b7ea4 SOFTE: 1 
  GPR00: d000000014822a14 c000001e34ce7a30 d0000000148cc018 c000001e37bc0000 
  GPR04: c000001db9ac0000 c000001e34ce7bc0 0000000000000000 0000000000000000 
  GPR08: 0000000000000001 c000001e34c30b50 0000000000000001 d0000000148278f8 
  GPR12: d0000000148b7e40 c00000000fb5b500 0000000000000000 000000000000001f 
  GPR16: 00003fff91c30000 0000000000800000 00003fffa8e34390 00003fff9242f200 
  GPR20: 00003fff92430010 000001001de5c030 00003fff9242eb60 00000000100c1ff0 
  GPR24: 00003fffc91fe990 00003fff91c10028 0000000000000000 c000001e37bc0000 
  GPR28: 0000000000000000 c000001db9ac0000 c000001e37bc0000 c000001db9ac0000 
  [  340.182315] NIP [d0000000148b7f10] kvmppc_vcpu_run_hv+0xd0/0xff0 [kvm_hv]
  [  340.182357] LR [d000000014822a14] kvmppc_vcpu_run+0x44/0x60 [kvm]
  [  340.182394] Call Trace:
  [  340.182413] [c000001e34ce7a30] [c000001e34ce7ab0] 0xc000001e34ce7ab0 
(unreliable)
  [  340.182468] [c000001e34ce7b70] [d000000014822a14] 
kvmppc_vcpu_run+0x44/0x60 [kvm]
  [  340.182522] [c000001e34ce7ba0] [d00000001481f674] 
kvm_arch_vcpu_ioctl_run+0x64/0x170 [kvm]
  [  340.182581] [c000001e34ce7be0] [d000000014813918] 
kvm_vcpu_ioctl+0x528/0x7b0 [kvm]
  [  340.182634] [c000001e34ce7d40] [c0000000002fffa0] do_vfs_ioctl+0x480/0x7d0
  [  340.182678] [c000001e34ce7de0] [c0000000003003c4] SyS_ioctl+0xd4/0xf0
  [  340.182723] [c000001e34ce7e30] [c000000000009204] system_call+0x38/0xb4
  [  340.182766] Instruction dump:
  [  340.182788] e92d02a0 e9290a50 e9290108 792a07e3 41820058 e92d02a0 e9290a50 
e9290108 
  [  340.182863] 7927e8a4 78e71f87 40820ed8 e92d02a0 <7d4022a6> f9490ee8 
e92d02a0 7d4122a6 
  [  340.182938] ---[ end trace bc5080cb7d18f102 ]---
  [  340.276202] 

  
  This was with the latest ubuntu cloud image. I get the same thing when trying 
to use virt-install with an ISO image. 

  I have no way of loading a KVM on 16.04.3

  == Comment: #2 - Jason M. Furmanek <furma...@us.ibm.com> - 2017-08-09 
17:42:34 ==
  I reinstalled with the HWE kernel (4.10).
  I can install VM and see the console and eveything seems fine.

  == Comment: #3 - Jason M. Furmanek <furma...@us.ibm.com> - 2017-08-09 
17:44:03 ==
  I had another system at 16.04.2 (4.4) and updated that one to the latest and 
it hit the same issue as above.
  No qemu or libvirt updates were applied. Just kernel updates and a handful of 
other stuff.

  Seems this issue is specific to the latest kernel

  old version worked:
  Linux fs7 4.4.0-83-generic #106

  new version did not:
  Linux fs7 4.4.0-89-generic #112-Ubuntu

  == Comment: #4 - Gustavo Bueno Romero <grom...@br.ibm.com> - 2017-08-09 
20:26:42 ==
  Looks like 46a704f8409f79fd66567ad3f8a7304830a84293 was backported on 88 but 
e47057151422a67ce08747176fa21cb3b526a2c9 was not:

  [gromero@localhost ubuntu-xenial]$ git remote -vv
  origin        git://kernel.ubuntu.com/ubuntu/ubuntu-xenial.git (fetch)
  origin        git://kernel.ubuntu.com/ubuntu/ubuntu-xenial.git (push)

  [gromero@localhost ubuntu-xenial]$ git log 
Ubuntu-4.4.0-83.106..Ubuntu-4.4.0-89.112 --oneline | fgrep "Preserve userspace 
HTM state properly"
  a97e978 KVM: PPC: Book3S HV: Preserve userspace HTM state properly
  [gromero@localhost ubuntu-xenial]$ git log 
Ubuntu-4.4.0-83.106..Ubuntu-4.4.0-89.112 --oneline | fgrep "Enable TM before 
accessing TM registers"
  [gromero@localhost ubuntu-xenial]$ git tag --contains 
a97e978574f41ffcf1813c180aba2772d46fbb5b
  Ubuntu-4.4.0-88.111
  Ubuntu-4.4.0-89.112
  Ubuntu-raspi2-4.4.0-1066.74
  Ubuntu-raspi2-4.4.0-1067.75
  Ubuntu-snapdragon-4.4.0-1068.73
  Ubuntu-snapdragon-4.4.0-1069.74

  So 
  
https://github.com/torvalds/linux/commit/46a704f8409f79fd66567ad3f8a7304830a84293
 is present in ISO but 
https://github.com/torvalds/linux/commit/e47057151422a67ce08747176fa21cb3b526a2c9
 is not.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-power-systems/+bug/1709784/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~group.of.nepali.translators
Post to     : group.of.nepali.translators@lists.launchpad.net
Unsubscribe : https://launchpad.net/~group.of.nepali.translators
More help   : https://help.launchpad.net/ListHelp

Reply via email to