** No longer affects: patchelf (Ubuntu Bionic)

** Summary changed:

- Please update to a newer version of patchelf
+ Please update to the newer version of patchelf in bionic

** No longer affects: patchelf (Ubuntu Artful)

-- 
You received this bug notification because you are a member of नेपाली
भाषा समायोजकहरुको समूह, which is subscribed to Xenial.
Matching subscriptions: Ubuntu 16.04 Bugs
https://bugs.launchpad.net/bugs/1753482

Title:
  Please update to the newer version of patchelf in bionic

Status in patchelf package in Ubuntu:
  New
Status in patchelf source package in Xenial:
  New

Bug description:
  [Impact]

   * New architecture support in xenial where the current version has FTBS 
e.g.; armhf, s390x
   * The new code adds logic to reorder Program Headers appropriately.
   * New feature (specific flag, --no-default-lib) to disable LD_LIBRARY_PATH

  [Test Case]

   * Use snapcraft's test suite which is a heavy user of patchelf.
   * snapcraft's test suite on the new architectures
   * patchelf's integrated tests
   * exploratory testing of patchelf.

  [Regression Potential]

   * Minimal possibility of patching to break on obscure binaries
   * 0.9-1 has already been available on artful and bionic with no bugs reported
   * No deb dependes on patchelf, snapcraft installs patchelf during runtime
     during runtime due to the FTBS. This would change that.

  [Other Info]

   * NixOS upstream https://github.com/NixOS/patchelf
   * Current version in artful and bionic: 0.9-1
   * Current version in xenial: 0.8-4. With FTBS for armhf and s390x

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/patchelf/+bug/1753482/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~group.of.nepali.translators
Post to     : group.of.nepali.translators@lists.launchpad.net
Unsubscribe : https://launchpad.net/~group.of.nepali.translators
More help   : https://help.launchpad.net/ListHelp

Reply via email to