** Changed in: pam (Ubuntu Trusty)
       Status: New => Won't Fix

** Changed in: pam (Ubuntu Xenial)
       Status: New => In Progress

** Changed in: pam (Ubuntu Artful)
       Status: New => In Progress

** Changed in: pam (Ubuntu Xenial)
     Assignee: (unassigned) => Seyeong Kim (xtrusia)

** Changed in: pam (Ubuntu Artful)
     Assignee: (unassigned) => Seyeong Kim (xtrusia)

-- 
You received this bug notification because you are a member of नेपाली
भाषा समायोजकहरुको समूह, which is subscribed to Xenial.
Matching subscriptions: Ubuntu 16.04 Bugs
https://bugs.launchpad.net/bugs/1538284

Title:
  [SRU] Unescaped left brace in regex is deprecated

Status in pam package in Ubuntu:
  Fix Released
Status in pam source package in Trusty:
  Won't Fix
Status in pam source package in Xenial:
  In Progress
Status in pam source package in Artful:
  In Progress
Status in pam package in Debian:
  Fix Released

Bug description:
  [Impact]

  When installing postgresql, many warning msgs are raised
  Please refer to Original Description

  ## Corrections
  In trusty, escaping is missing but not the same symptome. NOT AFFECTED TO 
TRUSTY

  [Test Case]

  1. create ubuntu instance
  2. apt install postgresql

  [Regression Potentials]
  This change is quite small(just escaping), and it is not code changes but 
getenv script which made by debian. so risk is minimal in my opinion.

  [Original Description]

  When installing postgresql on Ubuntu 16.04 (xenial), the following
  warning are raised:

  Unescaped left brace in regex is deprecated, passed through in regex; marked 
by <-- HERE in m/(?<!\\)\${ <-- HERE ([^}]+)}/ at /usr/sbin/pam_getenv line 78.
  Unescaped left brace in regex is deprecated, passed through in regex; marked 
by <-- HERE in m/(?<!\\)\${ <-- HERE ([^}]+)}/ at /usr/sbin/pam_getenv line 78.
  Unescaped left brace in regex is deprecated, passed through in regex; marked 
by <-- HERE in m/(?<!\\)\${ <-- HERE ([^}]+)}/ at /usr/sbin/pam_getenv line 78.
  Unescaped left brace in regex is deprecated, passed through in regex; marked 
by <-- HERE in m/(?<!\\)\${ <-- HERE ([^}]+)}/ at /usr/sbin/pam_getenv line 78.
  Unescaped left brace in regex is deprecated, passed through in regex; marked 
by <-- HERE in m/(?<!\\)\${ <-- HERE ([^}]+)}/ at /usr/sbin/pam_getenv line 78.
  Unescaped left brace in regex is deprecated, passed through in regex; marked 
by <-- HERE in m/(?<!\\)\${ <-- HERE ([^}]+)}/ at /usr/sbin/pam_getenv line 78.
  Unescaped left brace in regex is deprecated, passed through in regex; marked 
by <-- HERE in m/(?<!\\)\${ <-- HERE ([^}]+)}/ at /usr/sbin/pam_getenv line 78.
  Unescaped left brace in regex is deprecated, passed through in regex; marked 
by <-- HERE in m/(?<!\\)\${ <-- HERE ([^}]+)}/ at /usr/sbin/pam_getenv line 78.
  Unescaped left brace in regex is deprecated, passed through in regex; marked 
by <-- HERE in m/(?<!\\)\${ <-- HERE ([^}]+)}/ at /usr/sbin/pam_getenv line 78.
  Unescaped left brace in regex is deprecated, passed through in regex; marked 
by <-- HERE in m/(?<!\\)\${ <-- HERE ([^}]+)}/ at /usr/sbin/pam_getenv line 78.
  Unescaped left brace in regex is deprecated, passed through in regex; marked 
by <-- HERE in m/(?<!\\)\${ <-- HERE ([^}]+)}/ at /usr/sbin/pam_getenv line 78.
  Unescaped left brace in regex is deprecated, passed through in regex; marked 
by <-- HERE in m/(?<!\\)\${ <-- HERE ([^}]+)}/ at /usr/sbin/pam_getenv line 78.
  Unescaped left brace in regex is deprecated, passed through in regex; marked 
by <-- HERE in m/(?<!\\)\${ <-- HERE ([^}]+)}/ at /usr/sbin/pam_getenv line 78.
  Unescaped left brace in regex is deprecated, passed through in regex; marked 
by <-- HERE in m/(?<!\\)\${ <-- HERE ([^}]+)}/ at /usr/sbin/pam_getenv line 78.
  Unescaped left brace in regex is deprecated, passed through in regex; marked 
by <-- HERE in m/(?<!\\)\${ <-- HERE ([^}]+)}/ at /usr/sbin/pam_getenv line 78.

  This is due to the fact that unescaped brace are deprecated in Perl
  5.22.

  Info:

  root@xenial:/var/log/imscp# lsb_release
  No LSB modules are available.
  root@xenial:/var/log/imscp# lsb_release -a
  No LSB modules are available.
  Distributor ID:       Ubuntu
  Description:  Ubuntu Xenial Xerus (development branch)
  Release:      16.04
  Codename:     xenial

  Howto reproduce:

  aptitude install postgresql

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/pam/+bug/1538284/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~group.of.nepali.translators
Post to     : group.of.nepali.translators@lists.launchpad.net
Unsubscribe : https://launchpad.net/~group.of.nepali.translators
More help   : https://help.launchpad.net/ListHelp

Reply via email to