** Also affects: kmod (Ubuntu Trusty)
   Importance: Undecided
       Status: New

-- 
You received this bug notification because you are a member of नेपाली
भाषा समायोजकहरुको समूह, which is subscribed to Xenial.
Matching subscriptions: Ubuntu 16.04 Bugs
https://bugs.launchpad.net/bugs/1696710

Title:
  Ubuntu 16.04.02: depmod: WARNING: <module-path> needs unknown symbol
  .TOC.

Status in The Ubuntu-power-systems project:
  Fix Released
Status in kmod package in Ubuntu:
  Fix Released
Status in kmod source package in Trusty:
  In Progress
Status in kmod source package in Xenial:
  Fix Released

Bug description:
  == Comment: #0 - Douglas Miller <dougm...@us.ibm.com> - 2017-01-24 07:59:54 ==
  ---Problem Description---
  depmod does not handle .TOC symbol on powerpc platforms
   
  Contact Information = Douglas Miller <dougm...@linux.vnet.ibm.com> 
   
  ---uname output---
  Linux p8le03 4.4.0-38-generic #57-Ubuntu SMP Tue Sep 6 15:40:06 UTC 2016 
ppc64le ppc64le ppc64le GNU/Linux
   
  Machine Type = other 
   
  ---Debugger---
  A debugger is not configured
   
  ---Steps to Reproduce---
   Compile kernel, during modules_install target the messages appear. PPC64 
modules have a .TOC symbol which is required. It may be the only symbol with a 
period in the name, and so tools that restrict symbols based on a pattern may 
neglect to include .TOC.
   
  Userspace tool common name: depmod 
   
  The userspace tool has the following bit modes: 64 

  Userspace rpm: libkmod2:ppc64el

  Userspace tool obtained from project website:  na 
   
  *Additional Instructions for Douglas Miller <dougm...@linux.vnet.ibm.com>:
  -Attach ltrace and strace of userspace application.

  == Comment: #3 - Douglas Miller <dougm...@us.ibm.com> - 2017-01-24 08:12:58 ==
  kmod package:

  # dpkg --list |grep kmod
  ii  kmod                                           22-1ubuntu4                
         ppc64el      tools for managing Linux kernel modules
  ii  libkmod2:ppc64el                               22-1ubuntu4                
         ppc64el      libkmod shared library

  == Comment: #7 - Douglas Miller <dougm...@us.ibm.com> - 2017-06-07 16:20:38 ==
   I was doing a build of upstream origin/master on Ubuntu 16.04.2 fresh 
install and still getting these messages. In the "make modules_install" output 
I see:

  ...
    DEPMOD  4.12.0-rc4
  depmod: WARNING: 
/lib/modules/4.12.0-rc4/kernel/arch/powerpc/kernel/rtas_flash.ko needs unknown 
symb
  ol .TOC.
  ...

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-power-systems/+bug/1696710/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~group.of.nepali.translators
Post to     : group.of.nepali.translators@lists.launchpad.net
Unsubscribe : https://launchpad.net/~group.of.nepali.translators
More help   : https://help.launchpad.net/ListHelp

Reply via email to