This bug was fixed in the package neutron - 2:11.0.3-0ubuntu1.1

---------------
neutron (2:11.0.3-0ubuntu1.1) artful; urgency=medium

  * New upstream version.
  * d/p/call-update_all_ha_network_port_statuses-on-agent-start.patch:
    Dropped. Fixed in new upstream version.
  * New stable point release for OpenStack Pike (LP: #1758046).
  * d/neutron-openvswitch-agent.service.in,
    d/neutron-openvswitch-agent.neutron-ovs-cleanup.service.in:
    Revert changes made for LP:#1752838 due to regression (LP: #1758411).

 -- Corey Bryant <corey.bry...@canonical.com>  Thu, 22 Mar 2018 08:44:14
-0400

** Changed in: neutron (Ubuntu Artful)
       Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of नेपाली
भाषा समायोजकहरुको समूह, which is subscribed to Xenial.
Matching subscriptions: Ubuntu 16.04 Bugs
https://bugs.launchpad.net/bugs/1758411

Title:
  [SRU] Revert fix for bug 1752838 regression

Status in Ubuntu Cloud Archive:
  Fix Released
Status in Ubuntu Cloud Archive mitaka series:
  Fix Released
Status in Ubuntu Cloud Archive newton series:
  Fix Released
Status in Ubuntu Cloud Archive ocata series:
  Fix Released
Status in Ubuntu Cloud Archive pike series:
  Fix Released
Status in Ubuntu Cloud Archive queens series:
  Fix Released
Status in neutron package in Ubuntu:
  Fix Released
Status in neutron source package in Xenial:
  Fix Released
Status in neutron source package in Artful:
  Fix Released
Status in neutron source package in Bionic:
  Fix Released

Bug description:
  [Impact]

  The fix for the following bug was found to cause a regression/race
  with neutron-ovs-cleanup and neutron-openvswitch-agent where
  ports/flows get deleted and do not get restored.

  https://bugs.launchpad.net/ubuntu/+source/neutron/+bug/1752838

  [Test Case]
  * Deploy OpenStack Mitaka with one compute, one gateway and gre overlay
  * Create instance on gre overlay network
  * Add FIP to instance
  * Start a ping to FIP
  * juju ssh nova-compute/0
  * Check 'ovs-ofctl dump-flows br-tun' and observe table=20 egress flows for 
qdhcp and qrouter
  * systemctl restart openvswitch-switch
  * Check that flows re-added to br-tun (this takes a few seconds for 
neutron-openvswitch-agent to re-add them)
  * Check that ping still running

  [Regression Potential]

  There should be none as long as the code is reverted to what it was
  before the SRU for 1752838.

To manage notifications about this bug go to:
https://bugs.launchpad.net/cloud-archive/+bug/1758411/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~group.of.nepali.translators
Post to     : group.of.nepali.translators@lists.launchpad.net
Unsubscribe : https://launchpad.net/~group.of.nepali.translators
More help   : https://help.launchpad.net/ListHelp

Reply via email to