This bug was fixed in the package qemu - 1:2.5+dfsg-5ubuntu10.25

---------------
qemu (1:2.5+dfsg-5ubuntu10.25) xenial; urgency=medium

  [ Murilo Opsfelder Araújo ]
  * debian/patches/ubuntu/lp-1723914-ppc64-set-msr-register.patch:
    properly set MSR register for ppc64 targets (LP: #1723914)

  [ Yasmin Beatriz Alves da Silva ]
  * debian/patches/ubuntu/lp-1723904-sprs-backport.patch:
    Fix handling of Power8 special purpose registers (LP: #1723904)

 -- Christian Ehrhardt <christian.ehrha...@canonical.com>  Wed, 04 Apr
2018 12:46:15 +0200

** Changed in: qemu (Ubuntu Xenial)
       Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of नेपाली
भाषा समायोजकहरुको समूह, which is subscribed to Xenial.
Matching subscriptions: Ubuntu 16.04 Bugs
https://bugs.launchpad.net/bugs/1723914

Title:
  ubuntu-kvm-unit test failed with emulator test on ppc64le

Status in The Ubuntu-power-systems project:
  Fix Committed
Status in linux package in Ubuntu:
  Confirmed
Status in qemu package in Ubuntu:
  Fix Released
Status in linux source package in Xenial:
  New
Status in qemu source package in Xenial:
  Fix Released
Status in linux source package in Artful:
  New
Status in qemu source package in Artful:
  Fix Released

Bug description:
  [Impact]

   * on start of qemu-system-ppc64 MSR_SF is not set correctly
     So it doesn't start 64bit as it should

   * Todays guests usually work around this and are fine, but it is
     incorrect and might be an issue down the road. Furthermore this is also
     a fixup to some verification tests at the same time.

  [Test Case]

   * 1. deploy xenial + HWE kernel on a ppc64el box
     2. sudo apt-get install qemu-kvm -y
     3. git clone --depth=1 
https://git.kernel.org/pub/scm/virt/kvm/kvm-unit-tests.git
     4. cd kvm-unit-tests
     5. ./configure --endian=little; make
     6. sudo ppc64_cpu --smt=off
     7. sudo ./run_tests.sh -v

  [Regression Potential]

   * The changes are ppc only and provided by IBM so the potential risk is
     retained to the owner of the Area.
     Further the change is very small, so it has a very low amount of being
     misunderstood.

  [Other Info]

   * n/a

  ---

  Similar to bug 1723904, bug 1712803.
  The failed "emulator" test from kvm-unit-test will pass with qemu-2.7.1 built 
from source.

  ubuntu@modoc:~/kvm-unit-tests$ sudo /bin/bash -c "TESTNAME=emulator 
TIMEOUT=90s ACCEL= ./powerpc/run powerpc/emulator.elf -smp 1
  > "
  timeout -k 1s --foreground 90s /usr/bin/qemu-system-ppc64 -nodefaults 
-machine pseries,accel=kvm -bios powerpc/boot_rom.bin -display none -serial 
stdio -kernel powerpc/emulator.elf -smp 1 # -initrd /tmp/tmp.BJ2sE7V2Jc
  FAIL: emulator: 64bit: detected
  PASS: emulator: invalid: exception
  PASS: emulator: lswx: alignment
  PASS: emulator: lswi: alignment
  SUMMARY: 4 tests, 1 unexpected failures

  EXIT: STATUS=3

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.10.0-37-generic 4.10.0-37.41~16.04.1
  ProcVersionSignature: User Name 4.10.0-37.41~16.04.1-generic 4.10.17
  Uname: Linux 4.10.0-37-generic ppc64le
  ApportVersion: 2.20.1-0ubuntu2.10
  Architecture: ppc64el
  Date: Mon Oct 16 10:10:46 2017
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=<set>
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcLoadAvg: 0.00 0.00 0.57 1/1457 83356
  ProcLocks:
   1: POSIX  ADVISORY  WRITE 1604 00:14:19651 0 EOF
   2: POSIX  ADVISORY  WRITE 2937 00:14:55331 0 EOF
   3: FLOCK  ADVISORY  WRITE 3046 00:14:67623 0 EOF
   4: POSIX  ADVISORY  WRITE 3124 00:14:57398 0 EOF
   5: POSIX  ADVISORY  WRITE 3047 00:14:87068 0 EOF
  ProcSwaps:
   Filename                             Type            Size    Used    Priority
   /swap.img                               file         8388544 0       -1
  ProcVersion: Linux version 4.10.0-37-generic (buildd@bos01-ppc64el-026) (gcc 
version 5.4.0 20160609 (User Name/IBM 5.4.0-6ubuntu1~16.04.4) ) 
#41~16.04.1-User Name SMP Fri Oct 6 22:44:24 UTC 2017
  SourcePackage: linux-hwe
  UpgradeStatus: No upgrade log present (probably fresh install)
  cpu_cores: Number of cores present = 20
  cpu_coreson: Number of cores online = 20
  cpu_smt: SMT is off

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-power-systems/+bug/1723914/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~group.of.nepali.translators
Post to     : group.of.nepali.translators@lists.launchpad.net
Unsubscribe : https://launchpad.net/~group.of.nepali.translators
More help   : https://help.launchpad.net/ListHelp

Reply via email to