Fix released in the Ansible 2.0.0.2-2ubuntu1.3 package.

** Changed in: ansible (Ubuntu Xenial)
       Status: New => Fix Released

-- 
You received this bug notification because you are a member of नेपाली
भाषा समायोजकहरुको समूह, which is subscribed to Xenial.
Matching subscriptions: Ubuntu 16.04 Bugs
https://bugs.launchpad.net/bugs/1836961

Title:
  ansible 2.0.0.2-2ubuntu1.2 uninstallable on Ubuntu 16.04

Status in ansible package in Ubuntu:
  Invalid
Status in ansible source package in Xenial:
  Fix Released

Bug description:
  Ansible 2.0.0.2-2ubuntu1.2 was updated on July 12th and apparently
  just recently hit xenial updates and security:

  $ apt-cache policy ansible
  ansible:
    Installed: 2.0.0.2-2ubuntu1.2
    Candidate: 2.0.0.2-2ubuntu1.2
    Version table:
       2.1.1.0-1~ubuntu16.04.1 100
          100 http://archive.ubuntu.com/ubuntu xenial-backports/universe amd64 
Packages
   *** 2.0.0.2-2ubuntu1.2 500
          500 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 
Packages
          500 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 
Packages
          100 /var/lib/dpkg/status
       2.0.0.2-2 500
          500 http://archive.ubuntu.com/ubuntu xenial/universe amd64 Packages

  However, 2.0.0.2-2ubuntu1.2 has an error which prevents it from being
  installed properly:

  Setting up ansible (2.0.0.2-2ubuntu1.2) ...
  Sorry: IndentationError: unindent does not match any outer indentation level 
(constants.py, line 106)
  dpkg: error processing package ansible (--configure):
   subprocess installed post-installation script returned error exit status 101
  Setting up python-selinux (2.4-3build2) ...
  Errors were encountered while processing:
   ansible
  E: Sub-process /usr/bin/dpkg returned an error code (1)

  
  A more complete traceback:

  E: Sub-process /usr/bin/dpkg returned an error code (1)
  Traceback (most recent call last):
    File "/usr/bin/ansible-playbook", line 40, in <module>
      from ansible.utils.display import Display
    File "/usr/lib/python2.7/dist-packages/ansible/utils/display.py", line 35, 
in <module>
      from ansible import constants as C
    File "/usr/lib/python2.7/dist-packages/ansible/constants.py", line 106
      except OSError:
                    ^
  IndentationError: unindent does not match any outer indentation level
  --- 
  ProblemType: Bug
  ApportVersion: 2.20.9-0ubuntu7.7
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  DistroRelease: Ubuntu 18.04
  InstallationDate: Installed on 2018-06-01 (411 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
  Package: ansible 2.5.1+dfsg-1
  PackageArchitecture: all
  ProcEnviron:
   LANG=en_CA.UTF-8
   TERM=xterm-256color
   SHELL=/bin/bash
   XDG_RUNTIME_DIR=<set>
   PATH=(custom, user)
  ProcVersionSignature: Ubuntu 4.15.0-50.54-generic 4.15.18
  Tags:  bionic
  Uname: Linux 4.15.0-50-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip kvm lpadmin lxd plugdev sambashare sudo vboxusers
  _MarkForUpload: True

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ansible/+bug/1836961/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~group.of.nepali.translators
Post to     : group.of.nepali.translators@lists.launchpad.net
Unsubscribe : https://launchpad.net/~group.of.nepali.translators
More help   : https://help.launchpad.net/ListHelp

Reply via email to