Public bug reported:

== Impact ==
A Dell Edge Gateway 3002 user reported that `top` reports around 100% CPU usage 
for the libmbim-proxy process. Seen in at least 40% of their devices at some 
point during the last 6 months. The CPU keeps high at ~100% days or weeks, but 
does return back to normal without a reboot. The LTE connectivity is seemingly 
still working as usual.

The issue starts after an EPIPE error in the syslogs: 'cdc_mbim
1-3:1.12: nonzero urb status received: -EPIPE'.

== Fix ==
8fec9355a968 USB: cdc-wdm: ignore -EPIPE from GetEncapsulatedResponse
This has been in mainline kernel since 4.14.

== Testcase ==
Connect to the LTE network and see if libmbim-proxy uses 100% after some point.

== Risk of Regression ==
Low, since
1. Already tested by original reporter and no issue found after more than a 
week (usually it fails twice in a week).
2. Ignoring -EPIPE is the default behavior after 4.14.

** Affects: hwe-next
     Importance: Undecided
     Assignee: Jesse Sung (wenchien)
         Status: Fix Released

** Affects: linux (Ubuntu)
     Importance: Undecided
     Assignee: Jesse Sung (wenchien)
         Status: In Progress

** Affects: linux (Ubuntu Xenial)
     Importance: Undecided
     Assignee: Jesse Sung (wenchien)
         Status: In Progress


** Tags: oem-priority originate-from-1839516 plano

** Also affects: linux (Ubuntu Xenial)
   Importance: Undecided
       Status: New

** Changed in: linux (Ubuntu Xenial)
       Status: New => In Progress

** Changed in: linux (Ubuntu Xenial)
     Assignee: (unassigned) => Jesse Sung (wenchien)

** Tags added: oem-priority originate-from-1839516 plano

** Changed in: hwe-next
       Status: New => Fix Released

** Changed in: hwe-next
     Assignee: (unassigned) => Jesse Sung (wenchien)

-- 
You received this bug notification because you are a member of नेपाली
भाषा समायोजकहरुको समूह, which is subscribed to Xenial.
Matching subscriptions: Ubuntu 16.04 Bugs
https://bugs.launchpad.net/bugs/1851347

Title:
  libmbim-proxy using 100% CPU on a Dell Edge Gateway 3002

Status in HWE Next:
  Fix Released
Status in linux package in Ubuntu:
  In Progress
Status in linux source package in Xenial:
  In Progress

Bug description:
  == Impact ==
  A Dell Edge Gateway 3002 user reported that `top` reports around 100% CPU 
usage for the libmbim-proxy process. Seen in at least 40% of their devices at 
some point during the last 6 months. The CPU keeps high at ~100% days or weeks, 
but does return back to normal without a reboot. The LTE connectivity is 
seemingly still working as usual.

  The issue starts after an EPIPE error in the syslogs: 'cdc_mbim
  1-3:1.12: nonzero urb status received: -EPIPE'.

  == Fix ==
  8fec9355a968 USB: cdc-wdm: ignore -EPIPE from GetEncapsulatedResponse
  This has been in mainline kernel since 4.14.

  == Testcase ==
  Connect to the LTE network and see if libmbim-proxy uses 100% after some 
point.

  == Risk of Regression ==
  Low, since
  1. Already tested by original reporter and no issue found after more than a 
week (usually it fails twice in a week).
  2. Ignoring -EPIPE is the default behavior after 4.14.

To manage notifications about this bug go to:
https://bugs.launchpad.net/hwe-next/+bug/1851347/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~group.of.nepali.translators
Post to     : group.of.nepali.translators@lists.launchpad.net
Unsubscribe : https://launchpad.net/~group.of.nepali.translators
More help   : https://help.launchpad.net/ListHelp

Reply via email to