This bug was fixed in the package wslu - 2.3.2-0ubuntu2~18.04.0

---------------
wslu (2.3.2-0ubuntu2~18.04.0) bionic; urgency=medium

  * Backport to Bionic (LP: #1849679)

wslu (2.3.2-0ubuntu2) focal; urgency=medium

  * Suppress pulseaudio error on starting shell when pulseaudio-utils is 
installed
    (LP: #1844671)

wslu (2.3.2-0ubuntu1) eoan; urgency=medium

  [ Sebastien Bacher ]
  * debian/postinst, debian/prerm:
    - register also the www-browser alternative, the non-x-variant is
      used by xdg-open when DISPLAY is unset

  [ Balint Reczey ]
  * New upstream release
    - Fix support for Windows user names with space
  * Add autopkgtest
  * Fix saving configuration when the Windows user name contains space
  * Refresh patches

wslu (2.3.0-1ubuntu1) eoan; urgency=medium

  * debian/control: Set Vcs-* fields
  * New upstream release
    - Stop changing terminal font when running wsl* commands (LP: #1836208)
  * Refresh patches
  * debian/rules: Run tests in WSL only

wslu (2.0.0-0ubuntu3) eoan; urgency=medium

  * Set DISPLAY=:0 when an X11 server is running (LP: #1836552)
  * Use PulseAudio if it is running on Windows (LP: #1836552)
  * Set up sound, too, when starting GUI programs via Windows desktop shortcuts
    (LP: #1836552)

 -- Balint Reczey <rbal...@ubuntu.com>  Thu, 24 Oct 2019 16:15:20 +0200

** Changed in: wslu (Ubuntu Xenial)
       Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of नेपाली
भाषा समायोजकहरुको समूह, which is subscribed to Xenial.
Matching subscriptions: Ubuntu 16.04 Bugs
https://bugs.launchpad.net/bugs/1844671

Title:
  Pulseaudio error is shown starting Ubuntu terminal

Status in wslu package in Ubuntu:
  Fix Released
Status in wslu source package in Xenial:
  Fix Released
Status in wslu source package in Bionic:
  Fix Released
Status in wslu source package in Disco:
  Fix Released
Status in wslu source package in Eoan:
  Fix Released

Bug description:
  [Impact]

   * Pulseaudio error is shown starting Ubuntu terminal

  [Test Case]

   * Install Ubuntu WSL app on Windows 10 1909 or older version
   * Set up and start the Windows build of PulseAudio as described on 
https://wiki.ubuntu.com/WSL
   * Install wslu and pulseaudio-utils, then log out of the terminal
   * Start the terminal and observe no error message appearing on login, but 
appearing when running:
     $ pactl info
   * Also no error is shown when sourcing wsl-integration.sh twice:
     $ . /etc/profile.d/wsl-integration.sh
     $ . /etc/profile.d/wsl-integration.sh

  [Regression Potential]

   * Minimal. The change is just suppressing stderror from pactl on
  startup.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/wslu/+bug/1844671/+subscriptions

_______________________________________________
Mailing list: https://launchpad.net/~group.of.nepali.translators
Post to     : group.of.nepali.translators@lists.launchpad.net
Unsubscribe : https://launchpad.net/~group.of.nepali.translators
More help   : https://help.launchpad.net/ListHelp

Reply via email to