On Tue, Dec 17, 2013 at 10:27:12AM +0100, Francesco Lavra wrote: > > + grub_fdt_set_off_dt_strings (fdt, sizeof (*et)); > > + grub_fdt_set_off_dt_struct (fdt, sizeof (grub_fdt_header_t) + 16); > > I would write the offset as sizeof (et->header) + sizeof (et->empty_rsvmap)
True. Will change. > > +struct grub_fdt_empty_tree { > > + grub_fdt_header_t header; > > + grub_uint64_t empty_rsvmap[2]; > > + struct { > > + grub_uint32_t prop_start; > > + grub_uint8_t name[1]; > > + grub_uint32_t prop_end; > > + grub_uint32_t node_end; > > + } empty_node; > > Field names don't reflect their actual meaning: I would rename them as: > > struct { > grub_uint32_t node_start; > grub_uint8_t name[1]; > grub_uint32_t node_end; > grub_uint32_t tree_end; > } empty_tree; Yeah, sorry - I wrote that while analyzing the empty tree as generated bu dtc, and since it worked I never revisited when I understood things better after debugging. Will fix. / Leif _______________________________________________ Grub-devel mailing list Grub-devel@gnu.org https://lists.gnu.org/mailman/listinfo/grub-devel