HI,
it is finished now

> Am 11.04.2018 um 21:15 schrieb H. Nikolaus Schaller <h...@goldelico.com>:
> 
> Hi,
> 
>> Am 11.04.2018 um 17:15 schrieb Andreas Kemnade <andr...@kemnade.info>:
>> 
>> Hi,
>> 
>> On Fri, 6 Apr 2018 20:53:04 +0200
>> "H. Nikolaus Schaller" <h...@goldelico.com> wrote:
>> 
>>> Hi,
>>> 
>>>> Am 06.04.2018 um 20:37 schrieb Andreas Kemnade <andr...@kemnade.info>:
>>>> 
>>>> On Fri, 6 Apr 2018 08:50:37 +0200
>>>> Belisko Marek <marek.beli...@gmail.com> wrote:
>>>> 
>>>>> Hi,
>>>>> 
>>>>> I think it's due to the strict compiler in jessie then in older
>>>>> versions. I think it should be easily fixable. I tried yesterday do
>>>>> docker build for qtmoko but it's still wip but looks promising. Then
>>>>> we don't need any chroot on arm boards but we can do it easily on PC.
>>>>> Will provide more info when have some results.
>>>>> 
>>>> qt builds on jessie (the version inside the qtmoko tree where qdbus is
>>>> disabled) So the problem can be easily solved by disabling the same
>>>> amount of things in the ./configure in qtmoko-qte2 than in qtmoko
>>>> itself.
>>>> 
>>>> So the question was just whether it was intentional to have different
>>>> configure options there.
>>> 
>>> Probably nobody looked at that yet. There was enough work to get it
>>> compiled.
>>> 
>> Yes, can be the explanation. Just hesitating to change something
>> perhaps well thought of.
>> 
>>>> 
>>>>> P.S: which gcc version you have in jessie? I think fomr 5.x or 6.x
>>>>> while in older was 4.7 or 4.9
>>>>> 
>>>> 
>>>> 4.9
>>> 
>>> Hm. I still wonder why it worked for me with configure as it is.
>>> Maybe I should retry a clean build?
>>> 
>> yes, thas would be helpful.
> 
> Have started a complete fresh build (incl. all debootstrapping steps)
> now. Should run smoothly on 21% of a 200 GB µSD...
> 
> I can then go through the build log to see what it reports for
> qtmoko2-qte/source/src/dbus/qdbusintegrator.cpp

Well, it wasn't compiled at all!

Here are some snippets from the log:

Warning: PKG_CONFIG_PATH has not been set.  This could mean
the host compiler's .pc files will be used. This is probably
not what you want.

make[2]: Entering directory `/qtmoko2-qte/build/config.tests/unix/endian'
rm -f endiantest.o
rm -f *~ core *.core
rm -f endiantest
rm -f Makefile
make[2]: Leaving directory `/qtmoko2-qte/build/config.tests/unix/endian'
make[2]: Entering directory `/qtmoko2-qte/build/config.tests/unix/endian'
rm -f endiantest.o
rm -f *~ core *.core
rm -f endiantest
rm -f Makefile
make[2]: Leaving directory `/qtmoko2-qte/build/config.tests/unix/endian'
ln: failed to create symbolic link 
`/qtmoko2-qte/build/include/QtCore/qconfig.h': File exists
ln: failed to create symbolic link `/qtmoko2-qte/build/include/Qt/qconfig.h': 
File exists

Building on:   linux-debian-armhf
Building for:  qws/linux-debian-armhf
Architecture:  generic
Host architecture: arm

Build .................. libs examples demos docs translations
Configuration ..........  cross_compile system-sqlite release embedded 
largefile stl precompile_header exceptions_off  minimal-config small-config 
medium-config large-config full-config qt3support phonon phonon-backend 
accessibility shared embedded reduce_exports ipv6 clock-gettime clock-monotonic 
mremap getaddrinfo ipv6ifname getifaddrs inotify system-jpeg png system-tiff 
freetype system-zlib nis glib gstreamer concurrent multimedia audio-backend svg 
webkit script scripttools declarative release
Debug .................. no
Qt 3 compatibility ..... yes
QtDBus module .......... no
QtConcurrent code ...... yes
QtGui module ........... yes

/qtmoko2-qte/build/bin/moc -DQT_SHARED -DQT_NO_CAST_TO_ASCII 
-DQT_ASCII_CAST_WARNINGS -DQT3_SUPPORT -DQT_MOC_COMPAT -DQT_USE_QSTRINGBUILDER 
-DMAKE_PHONON_LIB -DQT_NO_DBUS -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_NETWORK_LIB 
-DQT_CORE_LIB -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE 
-I/qtmoko2-qte/source/mkspecs/qws/linux-debian-armhf 
-I/qtmoko2-qte/source/src/phonon -I../../include/QtCore 
-I../../include/QtNetwork -I../../include/QtGui -I../../include 
-I../../include/phonon -I.rcc/release-shared-emb-auto 
-I.moc/release-shared-emb-auto -I. 
/qtmoko2-qte/source/src/3rdparty/phonon/phonon/abstractaudiooutput.h -o 
.moc/release-shared-emb-auto/moc_abstractaudiooutput.cpp

If I understand correctly, it seems as if my sandboxed setup does NOT try to 
build dbus?

BR,
Nikolaus

Attachment: signature.asc
Description: Message signed with OpenPGP using GPGMail

_______________________________________________
Gta04-owner mailing list
Gta04-owner@goldelico.com
http://lists.goldelico.com/mailman/listinfo.cgi/gta04-owner

Reply via email to