Hi Jim,

I suspect this may have something to do with how gtk3/gnome3 is built and/or configured on the Mac. I have no experience with the jhbuild environment and have always used the MacPorts packages, but have never made any attempt to dig into how the latter are built. As I said, I was quite startled to find that my apps were somehow getting their fonts out of the MacOS font system rather than the fontconfig stuff used by most X11 servers. Perhaps gtk3 has some backdoor directly into the MacOS fonts that was enabled by the MacPorts build, or maybe somehow my XQuartz (2.7.7, xorg-server 1.15.2) has been built to use those fonts. Might be an interesting experiment to play with a non-gtk X11 client's fonts and see what happens.

As far as my use of $XDG_CONFIG_HOME/gtk-3.0/settings.ini, I based this strategy on


which reads

"GtkSettings provide a mechanism to share global settings between applications. On the X window system, this sharing is realized by an XSettings manager that is usually part of the desktop environment, along with utilities that let the user change these settings. In the absence of an Xsettings manager, GTK+ reads default values for settings from settings.ini files in /etc/gtk-3.0, $XDG_CONFIG_DIRS/gtk-3.0 and $XDG_CONFIG_HOME/gtk-3.0. These files must be valid key files (see GKeyFile), and have a section called Settings. ..."

Maybe the key phrase here is "In the absence of an Xsettings manager", i.e., you have one and I don't? Also of interest might be "On the X window system", implying that if someone used the direct-to-Quartz gtk backend this would not work then, either? It would certainly be nice to discover a strategy that worked under all these circumstances. I think that at this point I don't actually need my settings.ini file to get proper functionality with the default theme (now that my fonts are being correctly accessed), but I'm keeping it around mostly so users can alter the fontsize since I'm not running full-on gnome3 and there's no tweak-tool, etc., available. (I still can't install many of the gnome3 MacPorts packages because of a MacPorts package bug, and am at any rate not enthusiastic about loading up the system with all that weight just to run my own gtk app suite.)

You might try changing your font size value in settings.ini just to confirm whether that file is being read at all. That had an effect for me even when I could not get the font to change (before discovering I was trying to use the wrong fonts).

This is a murky swamp indeed!


From: Jim Charlton <char...@gmail.com>

I tried your font changing solution to alter the font for my gtk3
application.  I was unable to change the font by putting gtk-font-name
in settings.ini regardless of where I put that file or the value of the
environment variable XDG_CONFIG_HOME... or the actual font name.  I
found this to be true on both MAC OS X (Yosemite 1010, Gtk3 and Gtkmm3
built with jhbuild) and on my Linux Ubuntu box.
gtk-app-devel-list mailing list

Reply via email to