Hi Andy,

Andy 於 2017/8/8 下午 10:19 寫道:

I try sudo apt-get install glib-2.0
and is the same

Normally the package managers will not install the latest unstable versions of GLib, but only the stable versions that they support for their distribution release. So, you will need to build and install the latest unstable (2.53.x) version of GLib (make sure that you don't try to overwrite the GLib that your package manager provides, so you install it in a private location such as $HOME/gnome.build.unstable), and then when you build gobject-introspection, you need to prepend your ./autogen.sh with PKG_CONFIG_PATH= and LD_LIBRARY_PATH=, like:

LD_LIBRARY_PATH=$HOME/gnome.build.unstable/lib:$LD_LIBRARY_PATH PKG_CONFIG_PATH=$HOME/gnome.build.unstable/lib/pkgconfig:$PKG_CONFIG_PATH ./autogen (...whatever options you have)

Then you should be able to build and install it properly.

With blessings, and cheers!
_______________________________________________
gtk-devel-list mailing list
gtk-devel-list@gnome.org
https://mail.gnome.org/mailman/listinfo/gtk-devel-list

Reply via email to