Mark H Weaver <m...@netris.org> writes:

> Hi Marius,
>
> Marius Bakke <mba...@fastmail.com> writes:
>
>> I tried plugging in a USB drive on a GuixSD desktop system running from
>> the 'core-updates' branch and get this in dmesg:
>>
>> [198220.121488] udevd[173]: RUN{builtin}: 'uaccess' unknown 
>> /gnu/store/cfs89vshgfzxr9rr311pf2y6cifyjq4l-udev-rules/lib/udev/rules.d/73-seat-late.rules:15
>> [198300.595192] udevd[173]: RUN{builtin}: 'uaccess' unknown 
>> /gnu/store/cfs89vshgfzxr9rr311pf2y6cifyjq4l-udev-rules/lib/udev/rules.d/73-seat-late.rules:15
>
> FWIW, I see the same error on my GuixSD system based on 'core-updates',
> but for me it seems unrelated to USB drives.  The message is printed
> quite frequently, even if I never plug in a USB drive, and plugging in
> USB drives works perfectly for me.  The device nodes are automatically
> created, and the filesystems are mounted by GNOME.

Thanks for checking. I found the problem: I happened to upgrade to 4.12
at the same time and neglected to enable this new option:

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=2c93e790e8253552227bf9b46a8d49dca3f71b06

And failed to notice that the uhci-hcd module consequently went
AWOL. I've learned to read my kernel configuration commits and
not automatically assume core-updates is broken ;-)

I guess now we're just waiting for Hydra to finish the x86* builds.

Attachment: signature.asc
Description: PGP signature

Reply via email to