Hi,
Herman Rimm <[email protected]> skribis:
> How about only keeping the labels of `target-inputs`, and moving it to
> the `search-path-specification` record type? In lieu of my suggested
> `kind` field, build search paths have a `target-inputs` with (default)
> value `#f`, the CPATH (etc.) host search path would use `'("cross-libc"
> ...)`, and other host search paths would use a `'()` value.
>
> This way `bag` would have two types of inputs, and conceptually there
> would still only be two types of search paths.
So nothing would change?… Sorry, I’m trying to wrap my head around it
but I’m not sure I follow.
Could you clarify the problem we are trying to solve?
Thanks,
Ludo’.