Thomas,

There is no error message.  I thought I worded the question quite
well.  I will summarize as best I can.

Java code that I do not wish to change is calling a stored function in
H2 in PostgreSQL mode.  Java is pulling the value by name instead of
by index.

My question is, is there any way to change the name of the column
returned by a function in H2?


Referencing the column like this:

      id = resultSet.getString("getNextIdAndUpdate");

Is not going to work when the column is named this:

     PUBLIC.GETNEXTIDANDUPDATE()

-- 
You received this message because you are subscribed to the Google Groups "H2 
Database" group.
To post to this group, send email to [email protected].
To unsubscribe from this group, send email to 
[email protected].
For more options, visit this group at 
http://groups.google.com/group/h2-database?hl=en.

Reply via email to